We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 6726
    • 7,075 Posts
    Soda, about IE7 : no that wouldn’t be a good thing, because :
    1) it would add bulk to our js (IE7 was a js fix to IE CSS standard compliancy issues)
    2) it does not work if some IE user has js off, also Norton Security and such have caused problems with some js, you never know...

    There are many ways to achieve cross browser compatible designs, and it often involves little hacks like the _ thingy. I agree it’s not the best thing, but we have to handle MS IE and it’s the lighter way. The only thing about hacks is, I always comment them, you don’t know who will be in charge of websites you build in the future (and sometimes a reminder of why you did this or that is pretty helpful too tongue)

    Now back to testing : I have nothing to report yet, both installs and upgrades went fine, but maybe that’s because I am running PHP 5 / SQL 5 both locally and on my dedicated. I have read something about MySQL strict mode here and there : how do I turn it on / off ?

    It’d be nice to have people check their config when they get the blank page thing to see if that’s the cause of the problem.
      .: COO - Commerce Guys - Community Driven Innovation :.


      MODx est l'outil id
      • 28042 ☆ A M B ☆
      • 24,524 Posts
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 27889
        • 415 Posts
        how do I turn it on / off ?
        Type a sql request : SET sql_mode = "STRICT_TRANS_TABLES" check the different modes in manual.
        I find some info:
        Strict mode is the default for MySQL 5 also, disabling strict mode would only suppress the symptom, not the cause of the error.
        I can’t test it due to version number but :
        I noticed that MODx uses tables with columns of the type NOT NULL yet with no default value. This results in a bunch of queries failing. This problem can be solved by giving the columns empty default values.
          MODx Sites & Prestations: http://dp-site.fr [Last MODx Site]
          MODx Repository: [HOME] [MetaTagsExtra] / Current Dev: [xFDM]
          • 22303 MODX Staff
          • 10,725 Posts
          Quote from: Soda at Sep 12, 2006, 02:49 AM

          I noticed that MODx uses tables with columns of the type NOT NULL yet with no default value. This results in a bunch of queries failing. This problem can be solved by giving the columns empty default values.

          This is not necessarily a problem if the intention is to prevent insertion of a row without the minimum required data. Which specific table columns are we talking about?
            • 27889
            • 415 Posts
            Not a problem for mysql <5, but in the 5th version in strict mode it seems to raise somes errors (not tested).
            Lot of table (not checked all) have NULL define to no and no default value, for example, in site_content table, pagetitle, longtitle, description... have NULL to No but no default-value and these values are not set every time.
              MODx Sites & Prestations: http://dp-site.fr [Last MODx Site]
              MODx Repository: [HOME] [MetaTagsExtra] / Current Dev: [xFDM]
              • 22303 MODX Staff
              • 10,725 Posts
              Quote from: Soda at Sep 12, 2006, 03:06 AM

              Not a problem for mysql <5, but in the 5th version in strict mode it seems to raise somes errors (not tested).
              Lot of table (not checked all) have NULL define to no and no default value, for example, in site_content table, pagetitle, longtitle, description... have NULL to No but no default-value and these values are not set every time.
              Actually, those specific fields do have a default value: an empty string...as in...
              NOT NULL default ''

              However, menutitle and a few others do suffer from the problem you mention. But the real issue is whether or not the SQL is written properly. In any case, what issue are we talking about again (I think it’s time for some sleep)....
                • 27889
                • 415 Posts
                Sorry don’t see the ’’ smiley, DavidM can you check if the use of strict mode produce somes errors with sql on these type of table?
                  MODx Sites & Prestations: http://dp-site.fr [Last MODx Site]
                  MODx Repository: [HOME] [MetaTagsExtra] / Current Dev: [xFDM]
                  • 8382
                  • 253 Posts
                  Hi, All.
                  0.9.5 is very great job. I’ve benn testing rev1392 all the time for these two days.
                  I report some points that I noticed as a result.

                  manager/includes/lang/english.inc.php line 1233
                  "Document Manager:" is repeated twice.
                  I think, it’s better changing the name of the "Document Manager" to "Doc Manager", isn’t it?

                  I got error during exporting the sample site.
                  That was caused by coming to give back 404 code at config[’error_page’] page. maybe FS#255

                  This is my solutin.
                  1. Mark the access from export
                  manager/action/export_site.static.php line 124
                  		- if(@$handle = fopen($baseURL."/index.php?id=".$docid, "r")) {
                  		+ if(@$handle = fopen($baseURL."/index.php?id=".$docid."&z=manexp", "r")) {

                  2. Add a function to check if access is from export, into DocumentParser class
                    // check if access is from "Export Site"
                    function checkExport() {
                        if(isset($_REQUEST['z']) && $_REQUEST['z']=='manexp') {
                          return true;
                        } else {
                          return false;
                        }
                    }

                  3. Suppress sending 404 code when it is accessed from Export
                  manager/includes/document.parser.class.inc.php line 406
                        - if(($this->documentIdentifier == $this->config['error_page']) || $redirect_error) header('HTTP/1.0 404 Not Found');
                        + if((($this->documentIdentifier == $this->config['error_page']) && !($this->checkExport())) || $redirect_error) header('HTTP/1.0 404 Not Found');

                  This seems to be OK.

                  And I have made a Japanese lang file for beta, while testing the codes.
                  http://modxcms.com/forums/index.php/topic,6541.msg50050.html#msg50050
                  Would it be too early?

                  Sorry, my bad english.
                  Thanks
                    • 22303 MODX Staff
                    • 10,725 Posts
                    cool

                    Revision 1411 has been committed with some fixes to manager image paths, removal of existing references to visitor log tables, and, most importantly, a new API method and significant changes to the way sendErrorPage and sendUnauthorizedPage work.

                    First, the new method is $modx->sendForward($docId, $responseCode). This method will allow you to stop processing the current page, load a new page’s documentObject via document ID, and set any valid HTTP response code. It then processes the page as usual. This method is now used by sendErrorPage and sendUnauthorizedPage to forward page not founds or unauthorized requests to the configured page for each, while setting the appropriate HTTP response code (404 and 401, respectively). This should reduce bandwidth (no redirections) and improve the ability for server statistics and search engines to get an accurate view of your site.

                    We’ll be putting together a new test build with these changes in it today, so stay tuned. In the meantime, feel free to give it a try from the current SVN HEAD revision in trunk, and report your findings.
                      • 6726
                      • 7,075 Posts
                      Great news Jason, time to check out this rev then !
                      I’ll try this one out and report...

                      While I am here : I upgraded a miror of one of my MODx websites to 0.9.5 beta (rev1392) and I noticed that in Resources > Manage Resources > Template Variables the TVs were listed with the variable name field instead of the caption field, which is less readable. I don’t know if it was meant to be that way or broke during the upgrade process (I’ll check that).
                        .: COO - Commerce Guys - Community Driven Innovation :.


                        MODx est l&#39;outil id