Hi, All.
0.9.5 is very great job. I’ve benn testing rev1392 all the time for these two days.
I report some points that I noticed as a result.
manager/includes/lang/english.inc.php line 1233
"Document Manager:" is repeated twice.
I think, it’s better changing the name of the "Document Manager" to "Doc Manager", isn’t it?
I got error during exporting the sample site.
That was caused by coming to give back 404 code at config[’error_page’] page. maybe FS#255
This is my solutin.
1. Mark the access from export
manager/action/export_site.static.php line 124
- if(@$handle = fopen($baseURL."/index.php?id=".$docid, "r")) {
+ if(@$handle = fopen($baseURL."/index.php?id=".$docid."&z=manexp", "r")) {
2. Add a function to check if access is from export, into DocumentParser class
// check if access is from "Export Site"
function checkExport() {
if(isset($_REQUEST['z']) && $_REQUEST['z']=='manexp') {
return true;
} else {
return false;
}
}
3. Suppress sending 404 code when it is accessed from Export
manager/includes/document.parser.class.inc.php line 406
- if(($this->documentIdentifier == $this->config['error_page']) || $redirect_error) header('HTTP/1.0 404 Not Found');
+ if((($this->documentIdentifier == $this->config['error_page']) && !($this->checkExport())) || $redirect_error) header('HTTP/1.0 404 Not Found');
This seems to be OK.
And I have made a Japanese lang file for beta, while testing the codes.
http://modxcms.com/forums/index.php/topic,6541.msg50050.html#msg50050
Would it be too early?
Sorry, my bad english.
Thanks