We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 12379
    • 460 Posts
    Try using a different username for the SMF database than the one used for MODx.
      Mostly harmless.
      • 23265
      • 9 Posts
      « MODx Parse Error »
      MODx encountered the following error
      while attempting to parse the requested resource:
      « PHP Parse Error »

      PHP error debug
      Error: mysql_query(): supplied argument is not a valid MySQL-Link resource
      Error type/ Nr.: Warning - 2
      File: C:\wamp\www\modx\Forum\Sources\Subs.php
      Line: 323
      Line 323 source: $ret = mysql_query($db_string, $db_connection);

      Parser timing
      MySQL: 0.0030 s (4 Requests)
      PHP: 0.3878 s
      Total: 0.3908 s

      thats my problem and pl tell me some solutions for it

      thanks you so much
        • 23265
        • 9 Posts
        i run my modx on window xp with wamp server .
          • 3326
          • 1 Posts
          Quote from: philumo at Oct 23, 2007, 02:49 AM

          ...
          Line 323 source: $ret = mysql_query($db_string, $db_connection);
          ...
          i run my modx on window xp with wamp server .
          Looks like you don’t have a valid connection to your database, so i believe you have to check your database settings. You can find them in C:\wamp\www\modx\Forum\Settings.php at lines 40ff.
            • 23265
            • 9 Posts
            " Sorry, the copyright must be in the template.
            Please notify this forum’s administrator that this site is missing the copyright message for SMF so they can rectify the situation. Display of copyright is a legal requirement. For more information on this please visit the Simple Machines website."

            im always get this message when i click on forum link. i do exactly everything and i clear the :
            //$forum_copyright = preg_replace(’~(<a href="http://www.simplemachines.org/"[^>]+>)</a>~’, ’$1’ . $match[1] . ’</a>’, $forum_copyright);

            in subs.php and i clear "theme_copyright" in the index.template.php
            but im always get this message.

            and 2rd problem: my forum is always show a blank page before load the forum so i have cache forum without catching the forum is always blank page
            pls help me
              • 20044
              • 33 Posts
              about your 1st problem: smf really wants their copyright message in the template, so if you clear "theme_copyright" in your index template, you will end up with this error message. You could try enabling it again, and style it in the same font color as the background color.
                • 23265
                • 9 Posts
                thanks you and i solved that problem but i get 1 new

                i cant login or logout direct in Forum, i dont know why when i click on the Login or Register -> link to home page of Forumand i cant come back to out side.

                and 1 more problem: when i clear the cache , when i click on Forum the white page is how and when i refresh agian the layout is shown. i dont know 2 problem have relation or not. i think they relate together but i dont have any solution.

                i hope everybody can help me for solutions.

                thanks you
                  • 20044
                  • 33 Posts
                  about the Login/Register problem: If I understand your problem right I guess you should take a look at the module settings in the Manager: > Modules > manage modules > SMF connector > tab configuration. There you will find the id’s of the modx pages where the SMF login and registration links are redirected to.

                  the SMF connector ’hijacks’ the login, logout and registration links in SMF and redirects them to the MODx pages where you login, logout and register in MODX. So the forum login, logout and registration links are completely bypassed. Any user logging into modx does so automatically for the forum.
                    • 23265
                    • 9 Posts
                    i set everything as your says but nothing new. i cant login or logout . and the problem "blank page" beofre i link to forum nobody get it as me.

                    and at the end of page when i click on FORUM link always appear "1" number. i check many times but i dont know why does "1" appear at the bottom of page.

                    pls help me.

                    thanks you
                      • 25551 ☆ A M B ☆
                      • 1,231 Posts
                      I’m having a little trouble getting this to work... the plugin won’t run for a start and i get the following error on my local install of xampp. Anyone got a fix for this? I’m using the latest modx and smf builds.

                      « MODx Parse Error »
                      MODx encountered the following error while attempting to parse the requested resource:
                      « PHP Parse Error »
                       
                      PHP error debug
                        Error: 	include_once(C:/test/forum/") [function.include-once]: failed to open stream: No such file or directory	 
                        Error type/ Nr.: 	Warning - 2	 
                        File: 	C:\test\manager\includes\document.parser.class.inc.php(766) : eval()'d code	 
                        Line: 	2	 
                       
                      Parser timing
                        MySQL: 	0.0089 s	(4 Requests)
                        PHP: 	0.0553 s	 
                        Total: 	0.0642 s
                        Ross Sivills - MD AugmentBLU Edinburgh, Scotland UK
                        AugmentBLU - MODX Partner

                        BLUcart - MODX Revolution E-Commerce & Shopping Cart