We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 4129
    • 15 Posts
    Quote from: shtuck at Apr 23, 2007, 02:51 PM

    « MODx Parse Error »
    MODx encountered the following error while attempting to parse the requested resource:
    « PHP Parse Error »
     
    PHP error debug
      Error: 	filemtime() [function.filemtime]: open_basedir restriction in effect. File(/Load.php) is not within the allowed path(s): (/home/jackal/:/usr/lib/php:/usr/local/lib/php:/tmp)	 
      Error type/ Nr.: 	Warning - 2	 
      File: 	/home/jackal/public_html/shtuck/forum/Sources/Load.php	 
      Line: 	2135	 
      Line 2135 source: 	$key = md5($boardurl . filemtime($sourcedir . '/Load.php')) . '-SMF-' . $key;


    I think the variable $sourcedir = ’’ and it is not OK.

    I have noticed that the file "index_php.txt" joined in my first post was empty ! undecided I have updated it.

    So you need to do the following action specified in my first post :
    Replace the file "/forum/index.php" by the one joined in this post: Rename "index_php.txt" to "index.php" and put it in "/forum/" (use diff to see the differences if wanted).
      • 27136
      • 12 Posts
      after following those steps i now just get a blank page when i click on my forum link

      http://www.shtuck.com
        • 4129
        • 15 Posts
        A blank page means that you have a php error somewhere...

        To debug, could you add some "echo ’something’" in the file /forum/index.php in order to see exactly where is the problem coming from ?

        echo 'beginning of the file'
        ...
        
        echo 'debug1';
        require(dirname(__FILE__) . '/Settings.php');
        echo 'debug2';
        // And important includes.
        require_once($sourcedir . '/QueryString.php');
        echo 'debug3';
        require_once($sourcedir . '/Subs.php');
        echo 'debug4';
        require_once($sourcedir . '/Errors.php');
        echo 'debug5';
        require_once($sourcedir . '/Load.php');
        echo 'debug6';
        require_once($sourcedir . '/Security.php');
        echo 'debug7';
        ...
        
          • 27136
          • 12 Posts
          still getting a blank page with that code in the php file
            • 4129
            • 15 Posts
            Inside modx manager, remove the call to the snippet in the html page named "forum" (if you call it like this).

            Retry, you should see an empty page (=just the template).

            If not, then the error doesn’t come from the forum...
              • 27136
              • 12 Posts
              yes, just the template shows up

              this means its a problem with my forum?

              thanks
                • 4129
                • 15 Posts
                In order to not add too many messages in this post, I propose you to continue this in private mail (I have already sent one to you) and we’ll post back here the solution. tongue

                Thanks
                  • 21341
                  • 26 Posts
                  Hello,
                  i tried the bridge and it worked for a few moments. The SMF standalone works fine, but the integration about the snippet call results an empty page, administration and so on works fine, through modx or alone.

                  But this is not my question, i could reinstall and that problem should be solved. I want to integrate the forum into my site, but dont want to use short ULRs/ModRewrite.

                  The Gallery 2 Module works fine and i manage the albums through the modx URL of the gallery page. The gallery is in modx and never kills the layout. SMF showed up in modx, but kills the layout immediatly after clicking something.

                  Is such an integration possible?
                    • 16534
                    • 47 Posts
                    I need urgent assistance with this please. I installed the SMF bridge properly, and when I clicked apply module the login box on my forum disappeared and the main front page messed up as well.

                    My priority is not getting this to work now, but to get my forum back to working order. PLEASE can somebody tell me what SMF files this script modifies? It only happened as soon as I began to use the SMF module.
                      • 20682
                      • 31 Posts
                      I too am getting the blank page. After checking the db event log, i can see that the forum database info is messing with modx’s database info. It is looking for the template in a table within the smf db and not the modx db where the template exists.

                      I think integrating the smf database tables with modxs tables would solve the problem. But there are similar database table names, so a different prefix must be used.

                      UPDATE:

                      I transfered all the smf tables over to my modx db, amended the database settings in smf’s Settings.php and all is good!

                      The forum is actually within my modx page laugh

                      I’ll update further if there are any other tricks I figure out.

                      Sheri

                      Last update:
                      I have given up. After getting as far as I could, it is a exercise in futility. SMF requires the use of $_GET variables. Modx is not designed to use those! A simple link to your forum after integrating the web users is the way to go.