I could not solve this problem so I took a major chance and backed up the files and DB and then deleted everything on the server. I then create a new db with the same name and login. Then I did a fresh install of Revo. The fresh install worked but of course was blank. I made a backup of the fresh install. I then uploaded my original backuped files and overwrote the fresh install and imported the old db to the new one. That failed and gave me a white page with error on page and the manager allowed logon but was only a bunch of html links with no style and not functional.
Just prior to killing myself I uploaded the core congif file from the fresh install back up and...it worked!
Everything ok but some weird stuff, eg, some of my apostrophes turned into little question marks? I will paste one here: �
I’m pretty sure this problem was caused by the fact that the test domain was in a folder at
http://mydomain.ca/breakawaydistributing.com until it became live as a add-on domain.
Many thanks for everyone’s thoughts on this.