We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 3749
    • 24,544 Posts
    Stranger yet. Could that file or directory be part of a restricted Media Source in MODX?

    Can you load that log file in the Files section of the Manager, modify it, and save it?

      Did I help you? Buy me a beer
      Get my Book: MODX:The Official Guide
      MODX info for everyone: http://bobsguides.com/modx.html
      My MODX Extras
      Bob's Guides is now hosted at A2 MODX Hosting
      • 42415
      • 115 Posts
      Quote from: BobRay at Oct 30, 2018, 10:24 AM
      Stranger yet. Could that file or directory be part of a restricted Media Source in MODX?

      Can you load that log file in the Files section of the Manager, modify it, and save it?


      Yes I can load that file and save it in the files section of MODX manager, I put an extra space after "Could not open" and I could save it

      Downloading Files
      Version: modx-2.4.0-pl.zip
      URL: https://modx.s3.amazonaws.com/releases/2.4.0/modx-2.4.0-pl.zip
      Downloaded  -> /home/transpo2/public_html/ugmtemp/modx-2.4.0-pl.zip
      Could not open  /home/transpo2/public_html/core/cache/logs/upgrademodx.log
        • 3749
        • 24,544 Posts
        Try running the upgrade again.

        You haven't deleted the core/cache directory, right? [ed. note: BobRay last edited this post 7 years, 10 months ago.]
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 42415
          • 115 Posts
          I did not delete the core/cache.

          This time the upgrade from 2.3.9 to 2.4.0 was successful.

          There are no errors in the upgrademodx log

          However there are errors in the Install.config log file (see below):

          [2018-10-31 02:05:28] (ERROR in xPDOManager_mysql::addField @ /home/transpo2/public_html/core/xpdo/om/mysql/xpdomanager.class.php : 302) Error adding field transport.modTransportProvider->active: Array
          (
              [0] => 42S21
              [1] => 1060
              [2] => Duplicate column name 'active'
          )
          
          [2018-10-31 02:05:28] (ERROR in xPDOManager_mysql::addField @ /home/transpo2/public_html/core/xpdo/om/mysql/xpdomanager.class.php : 302) Error adding field transport.modTransportProvider->priority: Array
          (
              [0] => 42S21
              [1] => 1060
              [2] => Duplicate column name 'priority'
          )
          
          [2018-10-31 02:05:28] (ERROR in xPDOManager_mysql::addField @ /home/transpo2/public_html/core/xpdo/om/mysql/xpdomanager.class.php : 302) Error adding field transport.modTransportProvider->properties: Array
          (
              [0] => 42S21
              [1] => 1060
              [2] => Duplicate column name 'properties'
          )
          
          [2018-10-31 02:05:28] (ERROR in xPDOManager_mysql::addField @ /home/transpo2/public_html/core/xpdo/om/mysql/xpdomanager.class.php : 302) Error adding field modCategory->rank: Array
          (
              [0] => 42S21
              [1] => 1060
              [2] => Duplicate column name 'rank'
          )
          
          [2018-10-31 02:05:28] (ERROR in xPDOManager_mysql::addIndex @ /home/transpo2/public_html/core/xpdo/om/mysql/xpdomanager.class.php : 330) Error adding index rank to modCategory: Array
          (
              [0] => 42000
              [1] => 1061
              [2] => Duplicate key name 'rank'
          )
          
          [2018-10-31 02:05:28] (ERROR in xPDOManager_mysql::addIndex @ /home/transpo2/public_html/core/xpdo/om/mysql/xpdomanager.class.php : 330) Error adding index tmplvar_template to modTemplateVarResourceGroup: Array
          (
              [0] => 42000
              [1] => 1061
              [2] => Duplicate key name 'tmplvar_template'
          )
          
          [2018-10-31 02:05:28] (ERROR @ /setup/index.php) Error adding index user_occured to modManagerLog: No metadata defined
          [2018-10-31 02:05:31] (ERROR @ /setup/index.php) Could not copy /home/transpo2/public_html/core/packages/core/modContext/daaf224e93519d2a7ab7eb7044c24520/0/ to /home/transpo2/public_html/index.php
          [2018-10-31 02:05:31] (ERROR @ /setup/index.php) Could not copy /home/transpo2/public_html/core/packages/core/modContext/daaf224e93519d2a7ab7eb7044c24520/1/ to /home/transpo2/public_html/ht.access
          [2018-10-31 02:05:31] (ERROR @ /setup/index.php) Could not copy /home/transpo2/public_html/core/packages/core/modContext/7a6d878454764053a08ae73e7899fd47/0/ to /home/transpo2/public_html/manager/assets
          [2018-10-31 02:05:31] (ERROR @ /setup/index.php) Could not copy /home/transpo2/public_html/core/packages/core/modContext/7a6d878454764053a08ae73e7899fd47/1/ to /home/transpo2/public_html/manager/controllers
          [2018-10-31 02:05:31] (ERROR @ /setup/index.php) Could not copy /home/transpo2/public_html/core/packages/core/modContext/7a6d878454764053a08ae73e7899fd47/2/ to /home/transpo2/public_html/manager/templates
          [2018-10-31 02:05:31] (ERROR @ /setup/index.php) Could not copy /home/transpo2/public_html/core/packages/core/modContext/7a6d878454764053a08ae73e7899fd47/3/ to /home/transpo2/public_html/manager/min
          [2018-10-31 02:05:31] (ERROR @ /setup/index.php) Could not copy /home/transpo2/public_html/core/packages/core/modContext/7a6d878454764053a08ae73e7899fd47/4/ to /home/transpo2/public_html/manager/ht.access
          [2018-10-31 02:05:31] (ERROR @ /setup/index.php) Could not copy /home/transpo2/public_html/core/packages/core/modContext/7a6d878454764053a08ae73e7899fd47/5/ to /home/transpo2/public_html/manager/cache.manifest.php
          [2018-10-31 02:05:31] (ERROR @ /setup/index.php) Could not copy /home/transpo2/public_html/core/packages/core/modContext/7a6d878454764053a08ae73e7899fd47/6/ to /home/transpo2/public_html/manager/index.php
          [2018-10-31 02:05:31] (ERROR @ /setup/index.php) Could not install files from /home/transpo2/public_html/core/packages/core/xPDOFileVehicle/43658885512c425e7a878ce0fbeda2ba/ to /home/transpo2/public_html/connectors/
          [2018-10-31 02:05:31] (ERROR @ /setup/index.php) Could not install files from /home/transpo2/public_html/core/packages/core/xPDOFileVehicle/c86940a213053dc941cd7508ad1372df/ to /home/transpo2/public_html/connectors/
          [2018-10-31 02:05:31] (ERROR @ /setup/index.php) Could not install files from /home/transpo2/public_html/core/packages/core/xPDOFileVehicle/1c0f6d39c62bfbd91919e20d8eb5366e/ to /home/transpo2/public_html/connectors/
          [2018-10-31 02:05:31] (ERROR @ /setup/index.php) Could not install files from /home/transpo2/public_html/core/packages/core/xPDOFileVehicle/6f7e4f39b9b276f7be62dc56b3fb5192/ to /home/transpo2/public_html/connectors/
          
            • 3749
            • 24,544 Posts
            I think that could be your problem. Those new files are not getting copied. The addField and addIndex messages are normal. They just mean that those fields and indexes already exist in the DB.

            I see the same "failed to copy" and "failed to install" messages in the setup log at Bob's Guides, so there may be a problem with UpgradeMODX putting the files where setup expects to find them. I'll have to look into that.

            Check the permissions on the Manager, connectors, core/packages, and core/packages/core directories, and the permissions on the modx root directory, though I suspect that they're all fine.

            Worst case, I think you can download your version of MODX (traditional distribution), upload it to your site to a temp subdirectory, unzip it, and copy the files specified in the error messages to the location it says they belong.

            TBH, it might be easier to just follow the steps listed here: https://bobsguides.com/modx-upgrade-faq.html.

            Another option would be to roll back UGM to the previous version, reinstall that version, and use it to upgrade, though that would set the snippet properties back to their default settings (no problem if you haven't changed any of them).

            [UPDATE] Hold on. I just had another thought. Don't do anything until I check it out and get back to you.

              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 3749
              • 24,544 Posts
              OK, I think those file copy and install error messages are a red herring. I just upgraded a 2.5.7 site to 2.6.0 *without using UGM at all* and got the same messages in the setup log. It looks like I've been barking up the wrong tree and your problem is not caused by UGM. That's good news for me, but doesn't help you.

              Have you checked package Manager to see if any extras have updates available?

              Do you have any old extras, especially ones that operate in the Manager, that might be causing trouble?

              If you want to PM me some credentials, I can try to take a look at what's happening in the Manager. The safest way is to create a new user who is a member of the Administrator group with super user status, so you can delete that user later.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 42415
                • 115 Posts
                Hi Bob, sorry for late reply, I've been checking on a few things you mentioned.

                I have a list of extras running on old versions;

                formit
                google sitemap
                login
                migx
                pdotools
                personalize
                profiler
                query
                redirector
                tinymce

                However I think I may have found what the issue is; The MIGX version is 2.6.8

                In the changelog for MIGX it says the following;

                MIGX 2.8.0==============
                
                resolve tables on install
                render cross, also when empty string
                reusable activaterelations - processors
                [migxLoopCollection] tpl_nN
                [#154] clean TV-value, if no MIGX-items
                additional db-storage of formtabs and fields
                get menue working in MODX 2.3
                improve description_is_code


                #Note: get menue working in MODX 2.3

                MIGX 2.8.0 is the next version up from 2.6.8

                I remember when I did the initial upgrade from MODX 2.2.16 to 2.3 that none of the top menu items displayed in MODX manager, so I am thinking this is because I did not upgrade MIGX first. Unfortunately I just proceeded the upgrade from 2.3 to 2.4 which is where I am now.

                Ok, so now I will upgrade MIGX next but I am wondering which version to upgrade to? Is there a chronological sequence to follow similar to the UpgradeModx process?

                Or is it ok to just upgrade straight to MIGX 2.12.0 in package manager?
                • discuss.answer
                  • 3749
                  • 24,544 Posts
                  I looked at the MIGX commits and I don't see anything that would cause trouble if you went for the current version. The changes are all to the MIGX files. I wouldn't modify anything involving MIGX, though, until you get MODX up to 2.6.5.

                  Sorry I led you down the wrong path. You're the first person I've heard from who used the new version of UGM and I was afraid it was doing something wrong.


                  I think I would upgrade the other extras before upgrading MODX, but do it one at a time and check things out as you go. FYI, once you upgrade MODX, you may see even newer versions of some extras in Package Manager if they require later versions of MODX.
                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                    • 42415
                    • 115 Posts
                    So today I updated all the extras apart from MIGX
                    Next I ran the update from 2.4.0 to 2.5.0 and encountered the 'could not open upgrademodx log issue so I proceeded to open this log file in MODX manager, then edit and save it, then I proceeded with the update from 2.4.0 to 2.5.0.

                    This worked but I was unable to log into MODX manager. After a bit of Googling I found it was due to the 'createdon field in the modx_users table' that occasionally does not update when upgrade to 2.5.0. I found Bob Ray's solution which got me back into MODX manager:

                    https://bobsguides.com/blog.html/2016/06/27/missing-db-fields-(unknown-column)/

                    Next I proceeded to update to 2.6.0 then to 2.6.5 all ok front end and back end.

                    I did find some issues in the log file at core/cache/ install.config:

                    [2018-11-01 17:29:01] (ERROR @ /home/transpo2/public_html/core/xpdo/transport/xpdovehicle.class.php : 181) Could not copy /home/transpo2/public_html/core/packages/core/modContext/457ca7a0b0eaefc2ca1c7c6e01be469a/0/ to /home/transpo2/public_html/index.php
                    [2018-11-01 17:29:01] (ERROR @ /home/transpo2/public_html/core/xpdo/transport/xpdovehicle.class.php : 181) Could not copy /home/transpo2/public_html/core/packages/core/modContext/457ca7a0b0eaefc2ca1c7c6e01be469a/1/ to /home/transpo2/public_html/ht.access
                    [2018-11-01 17:29:01] (ERROR @ /home/transpo2/public_html/core/xpdo/transport/xpdovehicle.class.php : 181) Could not copy /home/transpo2/public_html/core/packages/core/modContext/55899c07a0be09d324666a6a7964aa95/0/ to /home/transpo2/public_html/manager/assets
                    [2018-11-01 17:29:01] (ERROR @ /home/transpo2/public_html/core/xpdo/transport/xpdovehicle.class.php : 181) Could not copy /home/transpo2/public_html/core/packages/core/modContext/55899c07a0be09d324666a6a7964aa95/1/ to /home/transpo2/public_html/manager/controllers
                    [2018-11-01 17:29:01] (ERROR @ /home/transpo2/public_html/core/xpdo/transport/xpdovehicle.class.php : 181) Could not copy /home/transpo2/public_html/core/packages/core/modContext/55899c07a0be09d324666a6a7964aa95/2/ to /home/transpo2/public_html/manager/templates
                    [2018-11-01 17:29:01] (ERROR @ /home/transpo2/public_html/core/xpdo/transport/xpdovehicle.class.php : 181) Could not copy /home/transpo2/public_html/core/packages/core/modContext/55899c07a0be09d324666a6a7964aa95/3/ to /home/transpo2/public_html/manager/min
                    [2018-11-01 17:29:01] (ERROR @ /home/transpo2/public_html/core/xpdo/transport/xpdovehicle.class.php : 181) Could not copy /home/transpo2/public_html/core/packages/core/modContext/55899c07a0be09d324666a6a7964aa95/4/ to /home/transpo2/public_html/manager/ht.access
                    [2018-11-01 17:29:01] (ERROR @ /home/transpo2/public_html/core/xpdo/transport/xpdovehicle.class.php : 181) Could not copy /home/transpo2/public_html/core/packages/core/modContext/55899c07a0be09d324666a6a7964aa95/5/ to /home/transpo2/public_html/manager/index.php
                    [2018-11-01 17:29:01] (ERROR @ /home/transpo2/public_html/core/xpdo/transport/xpdofilevehicle.class.php : 103) Could not install files from /home/transpo2/public_html/core/packages/core/xPDOFileVehicle/ffa5502778b3fb87d28d02f45d927841/ to /home/transpo2/public_html/connectors/
                    [2018-11-01 17:29:01] (ERROR @ /home/transpo2/public_html/core/xpdo/transport/xpdofilevehicle.class.php : 103) Could not install files from /home/transpo2/public_html/core/packages/core/xPDOFileVehicle/1149241767cb39815df8fc2114a9936f/ to /home/transpo2/public_html/connectors/
                    [2018-11-01 17:29:01] (ERROR @ /home/transpo2/public_html/core/xpdo/transport/xpdofilevehicle.class.php : 103) Could not install files from /home/transpo2/public_html/core/packages/core/xPDOFileVehicle/abadc8773bbd03d54796490a67534a63/ to /home/transpo2/public_html/connectors/
                    [2018-11-01 17:29:01] (ERROR @ /home/transpo2/public_html/core/xpdo/transport/xpdofilevehicle.class.php : 103) Could not install files from /home/transpo2/public_html/core/packages/core/xPDOFileVehicle/229a573898f3733982f59f406bed73e1/ to /home/transpo2/public_html/connectors/


                    Ignoring these I proceeded to update MIGX FROM 2.6.8 TO 2.12.0

                    I did have this following error in the MIGX install log:

                    Error adding index category to migxConfig: Array ( [0] => 42000 [1] => 1072 [2] => Key column 'category' doesn't exist in table )


                    However, Lo and behold my MIGX tables were found again in MODX manager link to MIGX smiley

                    The only difference I could see was I no longer has the CMP link in the top menu.

                    I have done some front end testing with forms, members and storing data to database and everything seems to be working ok. Am I correct in assuming those files that were not found or installed that showed up in the core/cache/ install.config are not so important?
                    Or do I still have to fix these?

                    Either way, a big thank you to Bob Ray for his super helpful advice and great website that lists so many MODX solutions smiley
                      • 3749
                      • 24,544 Posts
                      Am I correct in assuming those files that were not found or installed that showed up in the core/cache/ install.config are not so important?
                      Or do I still have to fix these?

                      TBH, I don't think those files even exist. I suspect that those same errors are in every setup log file. I think those files got removed from the build, but were not removed from the manifest. I could be wrong, but I see that same list of errors in all my MODX setup logs on all sites I've checked so far.

                      The MIGX install message is concerning, though, since it implies that there's a missing field in a MIGX table. I'd suggest starting a new topic with MIGX in the subject to get the author's attention, or posting in an existing MIGX support thread.
                        Did I help you? Buy me a beer
                        Get my Book: MODX:The Official Guide
                        MODX info for everyone: http://bobsguides.com/modx.html
                        My MODX Extras
                        Bob's Guides is now hosted at A2 MODX Hosting