We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 37653
    • 49 Posts
    Bonjour,
    On one of my modx site, i can't save snippet, plugin, TV or template.
    This not happen with resource or chunks.
    I have some others sites with this hoster with no problems.
    php version : 7.0.30
    modx version : 2.6.3

    I have deleted files on core/cache/
    relaunch setup/
    all extras are up to date
    What can i do to identify the bug ?

    Attached files : errors log , extra list

    /connectors/index.php:1 Failed to load resource: the server responded with a status of 404 ()
    modx.jsgrps-min.js:4 Uncaught TypeError: this.mask.addClass is not a function
        at S.onShow (modx.jsgrps-min.js:4)
        at S.afterShow (ext-all.js:21)
        at S.show (ext-all.js:21)
        at Object.show (ext-all.js:21)
        at MODx.onAjaxException (modx.js?v=f99f0ae8:122)
        at h.Event.fire (ext-all.js:21)
        at Ext.data.Connection.fireEvent (ext-all.js:21)
        at Ext.data.Connection.handleFailure (ext-all.js:21)
        at f (ext-base.js:21)
        at m (ext-base.js:21)

    This question has been answered by BobRay. See the first response.

    [ed. note: anatole44 last edited this post 8 years, 3 months ago.]
      • 38783
      • 571 Posts
      Attachments are not working on the forums at the moment. Please could you post your images somewhere else and provide links to them?

      Are the permissions all correct on the server?

      Do you have any extras or plugins installed that check syntax? These can sometimes cause a problem.
        If I help you out on these forums I would be very grateful if you would consider rating me on Trustpilot: https://uk.trustpilot.com/review/andytough.com

        email: [email protected] | website: https://andytough.com
      • discuss.answer
        • 3749
        • 24,544 Posts
        My money would be on mod_security as the culprit. Your host should be able to tell you whether this is the case by looking at their logs.

        That said, Andy could be right about it being an ill-behaved plugin. You can disable your plugins by right-clicking on them in the tree and manually deleting the cache files again.

        A date/timezone mismatch could also be causing trouble.
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 37653
          • 49 Posts
          Thank you for respons,

          I disable all plug-ins, erase all cache files. But the error still happen.

          i have this kind of error in logs. but i don't know what it could be
          1xx.xxx.xxx.71 - - [06/Jun/2018:16:52:50 +0200] "POST /connectors/index.php HTTP/1.0" 404 29983 "https://www.my-website.fr/manager/?a=element/plugin/update&id=19" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/66.0.3359.181 Safari/537.36"
          


          A date/timezone mismatch could also be causing trouble.
          I don't know where change that in manager.
            • 3749
            • 24,544 Posts
            Ah, check the connectors path and URL in the core/config.config.inc.php file.
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 37653
              • 49 Posts
              Nothing wrong whith connectors path
              if (!defined('MODX_CONNECTORS_PATH')) {
              
                  $modx_connectors_path= '/path/to/my/site/connectors/';
              
                  $modx_connectors_url= '/connectors/';
              
                  define('MODX_CONNECTORS_PATH', $modx_connectors_path);
              
                  define('MODX_CONNECTORS_URL', $modx_connectors_url);
              
              }


              I've switched recently to ssl on this site. And Other too without problems.

              server_protocol was http, i change it to 'https'
              link_tag_scheme was -1, i change it to 'https'

              Nothing change.

              Front is displaying without errors, the only thing is that i can't update snippet, plugins, tv, templates and ... systems settings (i change it in phpmyadmin). no problems updating resources and chunks.
                • 3749
                • 24,544 Posts
                The error message is telling you that the server can't reach the URL at https://yoursite.com/connectors/index.php, so either the connectors url is wrong, the file is missing, or there's a permission or ownership problem with the file or its directory.

                Try putting that URL in your browser's address bar. This would be the normal response:

                {"success":false,"message":"Access denied.","total":0,"data":[],"object":{"code":401}}
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 37653
                  • 49 Posts
                  Hi, if the this file is missing, nothing could run.
                  I have this respons.
                  {"success":false,"message":"Acc\u00e8s refus\u00e9.","total":0,"data":[],"object":{"code":401}}

                  What i had to try now is to duplicate the db and re-install the site in a subdomain and test it step by step. If i can get time.
                    • 3749
                    • 24,544 Posts
                    Hi, if the this file is missing, nothing could run.

                    No, that's not true. The front-end would run fine and so would the Manager as long as you didn't try anything that called a processor (like saving something).
                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting
                      • 37653
                      • 49 Posts
                      Thanks Bob, i have installed a modx (2.6.3) in other directory. With no extra and nothing else, just the common install. And I can't write any snippet.
                      /connectors/index.php:1 Failed to load resource: the server responded with a status of 403 (Forbidden)
                      

                      AND
                      modx.jsgrps-min.js:4 Uncaught TypeError: this.mask.addClass is not a function
                          at S.onShow (modx.jsgrps-min.js:4)
                          at S.afterShow (ext-all.js:21)
                          at S.show (ext-all.js:21)
                          at Object.show (ext-all.js:21)
                          at MODx.onAjaxException (modx.js?v=fe320b95:122)
                          at h.Event.fire (ext-all.js:21)
                          at Ext.data.Connection.fireEvent (ext-all.js:21)
                          at Ext.data.Connection.handleFailure (ext-all.js:21)
                          at f (ext-base.js:21)
                          at m (ext-base.js:21)


                      This on chrome Version 66.0.3359.181 (Build officiel) (64 bits)

                      The same errors on Safari Version 11.1 (13605.1.33.1.4)

                      The same errors on Firefox 47.0.1

                      Update :
                      I have this in my safari's console :
                      Failed to load resource: the server responded with a status of 404 (Not Found)
                      http://www.mysite.fr/manager/assets/modext/modx.jsgrps-min.js.map


                      I don't have modx.jsgrps-min.js.map in this folder.

                      [ed. note: anatole44 last edited this post 8 years, 3 months ago.]