On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Do you have any php.ini files that might be affecting behaviour?
      If I help you out on these forums I would be very grateful if you would consider rating me on Trustpilot: https://uk.trustpilot.com/review/andytough.com

      email: andy@andytough.com | website: https://andytough.com
    • Hi,

      Thanks for asking.

      But i have not made any custom php.ini files.

      thanks.
      • Yes, uncomment one (but not both) of the sections in the MODX .htaccess file that force www or non-www URLs.
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
        • Hi, Yes i tried that. Still no success. My current .htaccess is the following:

          Any other suggestions. This is driving me mad...

          And yes the mydomain.com in htaccess file is replaced with my my domain name.

          Thanks.

          # MODX supports Friendly URLs via this .htaccess file. You must serve web
          # pages via Apache with mod_rewrite to use this functionality, and you must
          # change the file name from ht.access to .htaccess.
          #
          # Make sure RewriteBase points to the directory where you installed MODX.
          # E.g., "/modx" if your installation is in a "modx" subdirectory.
          #
          # You may choose to make your URLs non-case-sensitive by adding a NC directive
          # to your rule: RewriteRule ^(.*)$ index.php?q=$1 [L,QSA,NC]

          RewriteEngine On
          RewriteBase /

          # Rewrite www.domain.com -> domain.com -- used with SEO Strict URLs plugin
          RewriteCond %{HTTP_HOST} .
          RewriteCond %{HTTP_HOST} !^mydomain\.fi [NC]
          RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
          RewriteCond %{REQUEST_URI} !^/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
          RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
          RewriteRule (.*) http://mydomain.fi/$1 [R=301,L]
          #
          # or for the opposite domain.com -> www.domain.com use the following
          # DO NOT USE BOTH
          #
          #RewriteCond %{HTTP_HOST} .
          #RewriteCond %{HTTP_HOST} !^www\.mydomain\.com [NC]
          #RewriteRule (.*) http://www.mydomain.com/$1 [R=301,L]

          # Rewrite secure requests properly to prevent SSL cert warnings, e.g. prevent
          # https://www.domain.com when your cert only allows https://secure.domain.com
          #RewriteCond %{SERVER_PORT} !^443
          #RewriteRule (.*) https://example-domain-please-change.com/$1 [R=301,L]

          # The Friendly URLs part
          RewriteCond %{REQUEST_FILENAME} !-f
          RewriteCond %{REQUEST_FILENAME} !-d
          RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
          RewriteCond %{REQUEST_URI} !^/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
          RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
          RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

          # Make sure .htc files are served with the proper MIME type, which is critical
          # for XP SP2. Un-comment if your host allows htaccess MIME type overrides.

          #AddType text/x-component .htc

          # If your server is not already configured as such, the following directive
          # should be uncommented in order to set PHP's register_globals option to OFF.
          # This closes a major security hole that is abused by most XSS (cross-site
          # scripting) attacks. For more information: http://php.net/register_globals
          #
          # To verify that this option has been set to OFF, open the Manager and choose
          # Reports -> System Info and then click the phpinfo() link. Do a Find on Page
          # for "register_globals". The Local Value should be OFF. If the Master Value
          # is OFF then you do not need this directive here.
          #
          # IF REGISTER_GLOBALS DIRECTIVE CAUSES 500 INTERNAL SERVER ERRORS :
          #
          # Your server does not allow PHP directives to be set via .htaccess. In that
          # case you must make this change in your php.ini file instead. If you are
          # using a commercial web host, contact the administrators for assistance in
          # doing this. Not all servers allow local php.ini files, and they should
          # include all PHP configurations (not just this one), or you will effectively
          # reset everything to PHP defaults. Consult www.php.net for more detailed
          # information about setting PHP directives.

          #php_flag register_globals Off

          # For servers that support output compression, you should pick up a bit of
          # speed by un-commenting the following lines.

          #php_flag zlib.output_compression On
          #php_value zlib.output_compression_level 5

          # The following directives stop screen flicker in IE on CSS rollovers. If
          # needed, un-comment the following rules. When they're in place, you may have
          # to do a force-refresh in order to see changes in your designs.

          #ExpiresActive On
          #ExpiresByType image/gif A2592000
          #ExpiresByType image/jpeg A2592000
          #ExpiresByType image/png A2592000
          #BrowserMatch "MSIE" brokenvary=1
          #BrowserMatch "Mozilla/4.[0-9]{2}" brokenvary=1
          #BrowserMatch "Opera" !brokenvary
          #SetEnvIf brokenvary 1 force-no-vary
          • I don't see anything wrong with your .htaccess file.

            It kind of looks like a problem with the connectors directory. You've already checked config.inc.php, but it wouldn't hurt to check again. Remember that the CONNECTORS_PATH should be the full file path to the connectors directory on the server, but the CONNECTORS_URL needs to be a URL.

            It could also be a problem with the permissions or ownership of the connectors directory or its files. It's easiest to check file and directory permissions in cPanel's File Manager.

              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
            • discuss.answer
              Hi,

              I contacted my host few days ago and described the problems. The customer service said that he is going to test something. And asked me to try everything again. Came back and the manager was totally messed up, like after a cache problems. So cleaned the cache files from server and everything started to work.

              I have asked my host what is exactly they did, because for me it seems that they knew what the problem was. I will inform if i get the answer from my host.

              Thanks for contributing for this and sorry that it was my host creating the problems. Never had any problems before with my host. i have been running modx installations there many years.

              Thanks
              • Who is your host?
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                • Hi,

                  My host is Louhi in finland. https://www.louhi.fi

                  They said that virtual memory was limited and did not work properly on the server. They said they took the virtual memory limit off and that was the solution. I do not know if it is true or not.

                  Thanks
                  • I'm glad you got it sorted. smiley
                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting