On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Quote from: dubbs at Mar 05, 2018, 11:10 AM
    So.. for those looking to get quipReply to work with recaptchaV2 do this...

    First install latest version of recaptchaV2 from here - https://modx.com/extras/package/recaptchav2

    Make the changes as described in this comment - https://forums.modx.com/thread/103038/quip-with-recaptcha-v2?page=5#dis-post-557140

    Then adapt your quipReply to read:
    [[!QuipReply? &thread=`article-ARTICLESRESOURCEIDHERE-[[*id]]` &preHooks=`recaptchav2` &closeAfter=`0` &moderate=`1` &requireAuth=`0` &recaptcha=`0` ]]


    Changing the ARTICLESRESOURCEIDHERE to be the resource ID of your resources blog in your site tree.

    Note - you need to make sure you add the:
    [[!recaptchav2_render]]
    <span class="quip-error"> [[!+error.recaptchav2_error]]</span>


    to your Reply Form Chunk.

    Note - this overrides the suggestion in the comment at https://forums.modx.com/thread/103038/quip-with-recaptcha-v2?page=5#dis-post-557140

    Should all work nicely now!

    dubbs.

    I can confirm that this works. Thanks a lot!
    • I've got recaptcha V2 working. Comments are added in Extras—>Quip—>Latest Comments but when approved don't display in the front end. The comments don't appear in the comments list of my Articles blog resource.

      This is my call...

      [[!QuipReply? &thread=`article-60-[[*id]]` &preHooks=`recaptchav2` &closeAfter=`0` &moderate=`1` &requireAuth=`0` &recaptcha=`0` ]]


      Any help would be much appreciated
        Web site design in Nottingham UK by Chris Fickling http://www.chrisficklingdesign.co.uk
      • OK I think I've got it - just in case this helps anyone else I also needed...
        <ul>
               [[!Quip? &thread=`article-60-[[*id]]`]]
        </ul>
          Web site design in Nottingham UK by Chris Fickling http://www.chrisficklingdesign.co.uk
        • I got this working, except that error messages do not appear. NOTE: I am NOT using Articles, I'm installing the quip comments scripts on all pages of the site.

          I've got Recaptcha V2 installed, correct keys enter in system settings, and the Recaptcha "I'm not a robot" element appears in the comments.

          When "I'm not a robot" IS checked off, the page redirects to itself with this on the end:

          ?quip_approved=0#quip-success-qcom

          and the comments shows up in my unapproved list.
          When "I'm not a robot" IS NOT checked, it redirects to itself with this on the end:

          #quip-comment-preview-box-qcom

          and no error message appears. The page doesn't scroll down, either, because there is no div with id "quip-comment-preview-box-qcom" on the page. The comment does not get entered in the database, as expected, but why no error message? I've got "[[!+error.recaptchav2_error]]" right after the Recaptcha display snippet in the reply template.
          [ed. note: rainbowtiger last edited this post 2 years, 6 months ago.]