We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!

Answered Hosting hell!!!

    • 51020
    • 670 Posts
    HI There,

    I have a customer who has already signed up for hosting on 1and1 (yes, I know...)

    I cannot even install modx on there - when i try to run the setup, I get this error:

    FATAL ERROR: MODX Setup cannot continue.

    To use PHP 5.3.0+, you must set the date.timezone setting in your php.ini. Please do set it to a proper timezone before proceeding. A list can be found here.

    I found the php.ini settings (there's no actual physical file I can access, just a settings page) but there is no option to update the date.timezone setting

    Obviously I have tried to contact 1and1, but no response - what a surprise..

    Just wondered on the off chance if anyone has come across this before, and found a way around it?!

    Thanks in advance!

    Andy

    This question has been answered by iusemodx. See the first response.

      • 50012
      • 12 Posts
      Hi Andy,

      To setup a modx-page on an "1und1" host just edit the index.php file in the "setup" folder and add this line right before the other "@ ini_set" in the top:

      @ ini_set('date.timezone', 'Europe/Berlin');


      Just edit your timezone from "Europe/Berlin" to your timezone. After that you should be able to setup your modx.

      Jan
        • 51020
        • 670 Posts
        Jan,

        You are a life saver - it worked perfectly.
        Thank you so much!
        I love the modx Community!

        :)
          • 51020
          • 670 Posts
          It connected to my database fine:

          Connecting to database server: Success!
          - Checking MySQL server version: OK! Running: 5.5.44-0+deb7u1-log
          - Checking MySQL client version: OK! Running: 5.0.11-20120503-$Id:15d5c781cfcad91193dceae1d2cdd127674ddb3e$

          ..but when I click → Create or test selection of your database I get this error;

          Checking database: MODX could not create your database. Please manually create your database and then try again.

          Any ideas?

            • 51020
            • 670 Posts
            Forget my previous comment - for some reason '1und1' decided to change the name of my database to the one I chose - of course they did!! lol

            Thanks again for your help
              • 50012
              • 12 Posts
              Hi Andy,

              i never had that problem. it is always a pleasure to work on a "1und1" server ... always new problems... smiley

              Does that post may work for you: https://forums.modx.com/thread/76142/error-on-installation-please-help

              Jan
                • 51020
                • 670 Posts
                Yep all fine now thank you! (sory, I've just had nothing but problems with 1and1 - I think the problem is their tech support is bad - but then again, they are very cheap - you get what you pay for i guess!
                  • 47401
                  • 295 Posts
                  Quote from: jdaehne at Oct 02, 2015, 05:15 AM
                  Hi Andy,

                  To setup a modx-page on an "1und1" host just edit the index.php file in the "setup" folder and add this line right before the other "@ ini_set" in the top:

                  @ ini_set('date.timezone', 'Europe/Berlin');


                  Just edit your timezone from "Europe/Berlin" to your timezone. After that you should be able to setup your modx.

                  Jan

                  i would set this in the php.ini file rather than in the index.php
                    • 51020
                    • 670 Posts
                    Quote from: comp_nerd26 at Oct 02, 2015, 06:21 AM
                    Quote from: jdaehne at Oct 02, 2015, 05:15 AM
                    Hi Andy,

                    To setup a modx-page on an "1und1" host just edit the index.php file in the "setup" folder and add this line right before the other "@ ini_set" in the top:

                    @ ini_set('date.timezone', 'Europe/Berlin');


                    Just edit your timezone from "Europe/Berlin" to your timezone. After that you should be able to setup your modx.

                    Jan

                    i would set this in the php.ini file rather than in the index.php

                    Yep - if you check the thread the problem was that with the 1and 1 hosting, that timezone setting doesn't appear int he php.ini settings, and you cannot edit the actual php.ini file, hence the workaround.

                      • 47401
                      • 295 Posts
                      in 1and1 control panel you can change the php.ini settings. i have 1and1 and have done this many times smiley