On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Ce qui est étrange, c’est que si je consulte la base dans MySQL, les champs ont bien les accents, c’est à l’affichage qu’ils sont remplacés huh
    • A l’affichage dans modx ?
      Vérifie que ton site fonctionne bien en UTF-8 (onglet Administration). On ne sait jamais.
        Sorry for my english. I'm french... My dictionary is near me, but it's only a dictionary !
      • J’ai bien utf8 dans mon manager. J’ai vérifié aussi phpMyAdmin et j’ai tout en utf8 (comme sur mon autre site)

        Pour info en local j’utilise la dernière version de XAMPP
        • Je connais XAMPP de nom uniquement. J’utilise les binaires de Apache, PHP et MySQL directement.

          Si quelqu’un à une idée... car je sèche.

            Sorry for my english. I'm french... My dictionary is near me, but it's only a dictionary !
          • Quote from: OncleBen31 at May 16, 2006, 11:14 AM

            Bonjour,

            J’ai fait un essai pour passer mon site en ligne vers un site local, pour pouvoir débugger des snippet.
            Et après avoir importer ma base de donnée, tous les accents ont été remplacés par des caractères étranges. Pourtant les deux serveur sont sur MySQL 5 et les deux sont configuré en UTF8_general_ci.

            Est-ce que j’ai fait une fausse manip ? Est-ce qu’il existe une solution pour éviter de reéditer toutes mes pages?

            PS : J’ai utilisé le module Mod_backup pour faire l’export
            Je pense que ton pb vient de la. Le module Mod_backup ne doit pas tenir compte de l’encodage.
            Peux tu refaire la manip mais cette fois ci en passant par phpmyadmin ?

            Il te faudra ensuite, via la console admin, revérifier le paramétrage.
            Personnellement, c’est cette méthode que j’utilise : export de la base puis import en local et modif paramètre.
            C’est un peu plus long mais je n’ai pas de pb ni en local ni sur le serveur distant.
              Marc
              I'm French... Sorry for my bad English, I use ' Google Translator' or other... but that remains that tools wink
            • Merci Marc je vais essayer. Est-ce qu’il faut utiliser des option particulières lors de l’export dans phpMyAdmin ?
              • J’ai utilisé les options par défaut pour l’exportation et ca marche nickel.

                Encore merci Marc, je vais refaire des essais avec le Mod_Backup et si il est en cause,, remonter le problème sur le forum.
                • SI c’est effectivement Mod_Backup qui pose un problème, peux tu me l’indiquer aisni que la version du module pour mettre à jour le tuto ?

                  Merci
                    Sorry for my english. I'm french... My dictionary is near me, but it's only a dictionary !
                  • C’est possible que cela soir lui qui pose problème mais je ne peux pas l’affirmer.

                    Ce qui est étrange :

                    • lorsque je fait l’export et l’import avec phpMyAdmin de mon hebergeur vers XAMPP, phpMyAdmin crée une base de données avec un intercalssement "latin1_german2_ci". Pourtant ca marche nickel au niveau des accents.
                    • En utilisant Mod_Backup : il ne fait pas une sauvegarde de la base mais des tables. J’ai donc essayer de créer une table pour acceuillir l’importation avec inteclassement à "utf8_general_ci" ou "latin1_german2_ci" sans succès. huh
                    • Je suis unpeu embétant je sais smiley mais si tu importes tes données (les tables avec le contenu) avec phpmyadmin dans une base existante, est ce que tu as le même problème ?
                        Sorry for my english. I'm french... My dictionary is near me, but it's only a dictionary !