On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hi,

    Since we actively support let's encryp initiative, we recently moved all our customer's website to https secured protocol.
    Everything worked fine (thanks to modx extreme versatility) but there is still one itchy problem with graviatar support.

    Because the image is called unsecure
    <img src="http://www.gravatar.com/avatar/whatever_id_string_is?s=50&d=identicon" class="quip-avatar" alt="">
    we are thrown insecure content warnings and we get the locker unlocked infamous icon....

    We tried to look in the article code a way to fix it, but even Mark's solution (https://www.markhamstra.com/modx/2012/07/3-tips-for-serving-a-modx-site-over-ssl/) injected into articleclass code (https://github.com/splittingred/Articles/blob/develop/core/components/articles/model/articles/article.class.php) does not seem to work.

    Is there someone who has been confronted to such an issue ?
    We would prefer not have to refurbish all our customers blog .... :-(
    There may be a way to force https in quip, but we have not found such a parameter.

    Any idea orhelp would be appreciate.

    Thanks.

    Philippe

    This question has been answered by Fildefer57. See the first response.

    • discuss.answer
      Thanks to the modx folks on slack.

      One solution is to change article setup in the advanced option, ____display, then modify default comment chunck with this code :


      <li class="[[+cls]]" id="[[+idprefix]][[+id]]" [[+depth_margin:notempty=`style="padding-left: [[+depth_margin]]px"`]]>
      <div id="[[+idprefix]][[+id]]-div" class="quip-comment-body [[+alt]]">
          <div class="quip-comment-right">
              [[+gravatarUrl:notempty=`<img src="[[+gravatarUrl:replace=`http://==//`]]" class="quip-avatar" alt="" />`]]
          </div>
       
          <p class="quip-comment-meta">
              <span class="quip-comment-author">[[+name]][[- +authorName]]:</span><br />
              <span class="quip-comment-createdon"><a href="[[+url]]">[[+createdon]]</a>
              [[+approved:if=`[[+approved]]`:is=`1`:then=``:else=`- <em>[[%quip.unapproved? &namespace=`quip` &topic=`default`]]</em>`]]
              </span>
          </p>
       
          <div class="quip-comment-text">
              <p>[[+body]]</p>
       
              [[+replyUrl:notempty=`<p><span class="quip-reply-link"><a href="[[+replyUrl]]">[[%quip.reply? &namespace=`quip` &topic=`default`]]</a></span></p>`]]
          </div>
       
          <div class="quip-comment-options">
              [[+report]]
              [[+options]]
          </div>
          <div class="quip-break"></div>
      </div>
          [[+children:notempty=`<ol class="quip-comment-list">[[+children]]</ol>`]]
      </li>

      Where replaced the
      [[+gravatarUrl:notempty=`<img src="[[+gravatarUrl]]" class="quip-avatar" alt="" />`]]

      with :
      [[+gravatarUrl:notempty=`<img src="[[+gravatarUrl:replace=`http://==//`]]" class="quip-avatar" alt="" />`]]


      as a dirty fix.

      On the logn term, may be quip could be modified to check the current url scheme and use it ...