This happens when the URL to a resource, such as a MODX extra, is forwarded to another location such as the Amazon repository where MODX keeps its files. cURL can't go beyond the first URL using its CURLOPT_FOLLOWLOCATION option.
PHP since 2013 has resolved the problem, so it depends on your version of PHP.
If you can't get safe_mode (which has been removed altogether from PHP since version 5.4.0) and open_basedir turned off, I would just disable the configuration check widget in the Dashboard. It doesn't really have much use once your site is installed.
http://php.net/manual/en/features.safe-mode.php
http://php.net/manual/en/ini.core.php#ini.open-basedir
http://stackoverflow.com/questions/25812486/why-was-curlopt-followlocation-made-incompatible-with-open-basedir?lq=1
If all else fails, consider moving to a more useful hosting provider. I'd recommend SkyToaster in that case.