On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hi, I've recently upgraded to Evo 1.0.15. It wasn't possible to do a DB backup and I did not build the original site so I am at a bit of a loss. Oh, and I'm not very familiar with ModX.

    Anyway, everything works well, except that we now get a Page Not Found error in a popup window when trying to insert images.


    The paths to File Manager and File Browser must somehow be wrong?

    What is confusing me is that the directory tree is set up as

    public_html
    modx
    uploads

    and all the images, etc are in uploads/files and uploads/images.

    All the directories in uploads have permissions of 0755

    The individual Manager User paths are blank.

    _SERVER["DOCUMENT_ROOT"] is /home/masv/public_html
    PHP Version 5.5.30
    _SERVER["SERVER_SOFTWARE"] Apache

    What should I set the main paths to? And do I use Tools->Configuration->FileManager and Tools->Configuration->FileBrowser for that?

    • If I recall correctly, the Configuration should have buttons to correct these paths if necessary. Do make sure that your browser cookies and cache are cleared so that it's not trying to use old JS and other files.

      Also check your user's settings to make sure that they are using the correct paths, or the system default.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
      • Quote from: sottwell at Dec 11, 2015, 01:15 AM
        If I recall correctly, the Configuration should have buttons to correct these paths if necessary.

        It does, but they set the paths to [(base_path)] and that doesn't work.

        I wonder if it's because everything in is an uploads folder and not under ModX/assets? Or doesn't it matter?

        Quote from: sottwell at Dec 11, 2015, 01:15 AM

        Do make sure that your browser cookies and cache are cleared so that it's not trying to use old JS and other files.

        Good idea, and I have done it, but if I am telling it which path to use as a setting, shouldn't it ignore the user's own cache? Anyway, it makes no difference.

        I know there's a button that seems to be for flushing the site cache, but that seems to be the only thing keeping the site's images in place so I'm not keen to click it.

        Quote from: sottwell at Dec 11, 2015, 01:15 AM

        Also check your user's settings to make sure that they are using the correct paths, or the system default.

        No, their settings are blank. I would expect that to tell ModX to use the system defaults. That IS correct, right?
        • I haven't used Evo for years, so that's the best I can offer.
            Studying MODX in the desert - http://sottwell.com
            Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
            Join the Slack Community - http://modx.org
          • Well... thanks all the same.

            Anybody else have any ideas?
            • Quote from: vince_masv at Dec 11, 2015, 11:32 AM
              Well... thanks all the same.

              Anybody else have any ideas?

              I am working on the same issue with a 1.0.15 site. The configuration says the File Browser path is [(base_path)]assets/ , but when the browser picks up an image from the directory, it puts /images/filename.jpg as the path to the image instead of /assets/images/filename.jpg. Uploading the file puts the image in the correct directory, i.e. /assets/images, but the browser puts the wrong path in.

              I am pretty familiar with ModX.

              Jeff Small
              jsmall@Linux25.com
              • In case you mention it, the File Manager path has no effect on this behaviour.

                JEff SMall
                jsmall@Linux25.com
                • Here are some things I advice in such situation:

                  1. If there is any .htaccess file at the root of your site, check that it is correctly set.
                  Redirection issues may come from here.

                  2. In MODx Evolution > Tools > Configuration > File Manager (Tab),
                  check that the File manager button is set to [(base_path)]
                  and click the "Empty" button if it is not.

                  3. In MODx Evolution > Tools > Configuration > File Browser (Tab),
                  check that the path to the files directory is set to : [(base_path)]assets/
                  and click the "Empty" button if it is not.

                  4. Make "Site > Clear cache".
                  Reading the message returned, check that cached files were not only found but actually deleted.

                  5. If necessary, locally or in FTP, go in the "asset/cache" directory and delete the cache files, which ends with ".idx.php" (MODx will recreate them automatically).

                  7. If you're using Mozilla Firefox, there seem being sometimes some kind of session cache that is reluctant to deletion. Close the MODx tabs, clear the MODx cache, close Firefox and restart it.

                  8. If this does not suffice, test with another browser, like Internet Explorer.
                  This will help knowing if the problem is browser-related or not.

                  9. As for the frontend of your website, also check that in your templates the <base href="http://something.../" /> tag is set correctly.