We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 40122
    • 330 Posts
    I am getting the error:

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 72 bytes) in /home/mainsite/public_html/clientsite/core/xpdo/xpdo.class.php on line 1793

    when I try to create a new Resource in the Manager.

    I have read this is due to having 2 Resources that reference each other, thus creating an endless loop. But I dont see how this could work here on the manager side. Front end works fine.

    Would anyone know what could be causing this and how to fix?

    Also, where/what is php.ini?

    Many thanks in advance!

    EDIT: uninstalled getResources to see if that was causing it. Issue still persists. [ed. note: meltingdog last edited this post 10 years, 10 months ago.]
      • 3749
      • 24,544 Posts
      If you drag resources in the tree, sometimes MODX gets confused. It's possible for two resources to have each other as parents or for a resource to have itself as its parent. This isn't necessarily your problem, but if it is, you can check the 'parent' column in the modx_site_content table in the DB (SiteCheck will also do the search for you, though it's not free).

      You might first try disabling all your plugins (right-click on them in the Elements tree), then manually delete all files in the core/cache directory. If that fixes the problem, it's a good bet that two plugins are triggering each other in an endless loop, or one plugin has an endless loop in its code.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting