No, there is no advantage to having the core anywhere else within the web root. The whole point of putting the core outside of the web root is that a web server can only serve files from within its web root (www, public_html, htdocs, etc). The core never needs to be accessed by the web server, all of its files are included through the file system.
If you cannot create a folder above the web root for the core, the next best thing is to configure the web server to deny all requests to the files in the core. For example, an Apache .htaccess file in the /core/ directory would have
IndexIgnore */*
<Files *>
Order Deny,Allow
Deny from all
</Files>
The <Files *> means "any file", and this directive tells the web server to deny all requests to any files. So any request to domain.com/core/<any file> would be denied.