On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I'm having some trouble with the extra cssSweet.
    @import partials aren't compiling into the final css file. It is treating @import's like regular css would, and looking for that css file to link to the page rather than adding it to the compiled file. The only way I can seem to get multiple files compiled together is to add each chunk in to the custom_scss_chunks property. Even then, the partials aren’t properly being added.

    Am I missing something?

    For example, have scss_import_paths property set to scss/ and there I have _myPartial.scss.

    My custom_scss_chunks just include myStyle.scss. myStyle.scss includes @import 'myPartial';

    But when I save and clear the cache, rather than add the contents of myPartials to custom_css.min.css it looks to add mysite.com/assets/somponents/csssweet/scss/myPartial to the page a regular css link.

    Help! Am I missing something? If so I would appreciate some help. This extra seems like it would be totally awesome if I can get it dialed in.

    Thanks!

    This question has been answered by chenrupo. See the first response.

    • discuss.answer
      And of course right after I post a question, I figure it out! Thanks to Y.J. Tso for replying to my email and getting me sorted out! Here is what he said:

      The default path property is an empty value. The value you're using `assets/site/scss` is a relative path. Can you please try it with the filesystem path? It would be something like `/home/username/public_html/assets/site/scss`

      Or you can use the config placeholder: `[[++assets_path]]site/scss` but in that case make sure the enable the "Process tags in properties" checkbox at the bottom of the Properties tab in the Plugin edit view.

      I went with the placeholder, and now everything is working great!