We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 15152
    • 360 Posts
    I am having an issue upgrading to Revo 2.4. The manager (see attached) is not working properly - no doc tree and nothing else is working. The install is giving me the errors below (attached). Also, I am unable to log out of the manager now. I have uploaded the install files a couple of times, cleared the cache folder, and run setup again but I get the same issue.

    This question has been answered by jwmsales. See the first response.

      There are no boring projects. Only boring executions. ~ Etzkorn
      www.impress-design.com
      • 3749
      • 24,544 Posts
      The error messages are probably normal. What version of PHP are you running? Do you have the compress_js and compress_css System Settings turned off? If not, turn them off.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 15152
        • 360 Posts
        Hey, Bob,
        Thanks for replying. I have compress_js and compress_css turned off and the server is running php 5.3.
          There are no boring projects. Only boring executions. ~ Etzkorn
          www.impress-design.com
          • 3749
          • 24,544 Posts
          2.4 requires PHP 5.3.3, so make sure you have that.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 15152
            • 360 Posts
            I think that is it Bob. The site is on an older Hostgator server and I am moving (now). The server is running php 5.3. Once I move the site if I get it running I will mark this solved.

            Thanks
              There are no boring projects. Only boring executions. ~ Etzkorn
              www.impress-design.com
              • 15152
              • 360 Posts
              Didn't help, moving the site. I am having the same issues. I have re-installed the script and nothing changes. That's on two different servers.
                There are no boring projects. Only boring executions. ~ Etzkorn
                www.impress-design.com
                • 3749
                • 24,544 Posts
                Try disabling your plugins, you may have one that's incompatible with 2.4.

                BTW, whenever I see something like that after an upgrade and clearing the cache files, it's almost always a browser cache issue.
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 15152
                  • 360 Posts
                  Not a browser cache issue. Still can't figure out where the issue is.

                  I am getting these error messages in the manager:

                  [Error] SyntaxError: Unexpected token ':'. Parse error.
                  (anonymous function) (modx.config.js.php, line 1)
                  [Error] TypeError: undefined is not an object (evaluating 'MODx.config['upload_files'].toLowerCase')
                  (anonymous function) (multiuploaddialog.js, line 3)
                  global code (multiuploaddialog.js, line 563)
                  [Warning] Unexpected CSS token: : (manager, line 265)
                  [Error] TypeError: undefined is not an object (evaluating 'MODx.user.id')
                  readState (modx.js, line 879)
                  HttpProvider (modx.js, line 734)
                  Layout (modx.layout.js, line 25)
                  Default (layout.js, line 6)
                  create (ext-all.js, line 21)
                  load (modx.js, line 85)
                  (anonymous function) (manager, line 51)
                  (anonymous function) (ext-all.js, line 21)
                  b (ext-all.js, line 21)
                  [Error] TypeError: undefined is not an object (evaluating 'this.proxy.request')
                  handleError (ext-all.js, line 21)
                  handleException (ext-all.js, line 21)
                  load (ext-all.js, line 21)
                  Grid (modx.grid.js, line 105)
                  RecentlyEditedResourcesByUser (modx.grid.user.recent.resource.js, line 46)
                  create (ext-all.js, line 21)
                  load (modx.js, line 85)
                  (anonymous function) (manager, line 58)
                  (anonymous function) (ext-all.js, line 21)
                  b (ext-all.js, line 21)
                  [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (s.gif, line 0)
                    There are no boring projects. Only boring executions. ~ Etzkorn
                    www.impress-design.com
                    • 3749
                    • 24,544 Posts
                    It looks like a missing or corrupted file in your MODX install. This is fairly common if you transfer the files individually with FTP.

                    You might try the UpgradeMODX extra. If you set the settings_version System Setting to 2.3.9-pl, it will re-download all the files and do a new upgrade install.
                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting
                      • 15152
                      • 360 Posts
                      I have used UpgradeMODX and copied them manually via SFTP. No luck either way.
                        There are no boring projects. Only boring executions. ~ Etzkorn
                        www.impress-design.com