We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 40762
    • 54 Posts
    It seems I have a similar problem. Could you tell me how I can debug this better. I am not getting any errors in the logs. I tried the latest fix witout any success and I have disabled all plugins. I have also tried to install 2.4.1 after these steps and clear my cache.

    Any help would be very appreciated

    Mark
      Marc-Andre Audet
      • 3749
      • 24,544 Posts
      Make sure you're running at least PHP version 5.3.3.

      Delete all files in the core/cache directory
      Use Private or incognito mode in your Browser
      Turn off compress_js and compress_css System Settings in the modx_system_settings table in the DB (change the 1 to a 0)
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 40762
        • 54 Posts
        Hey guys, Just to let you know that I solved the problem. I was having problems with .gitignore files overriding my config.core.php. Very confusing but its all working now. Sorry for the post.

        Mark
          Marc-Andre Audet
          • 11681
          • 98 Posts
          First, my apology to Bob Ray for missing his admonition to post here instead of communicating via his site's contact form. I saw that note just after hitting the 'submit' button. Bad manners!

          I (rashly?) attempted to use UpgradeMODX 1.4.0-pl to upgrade a site from MODX 2.2.14-pl directly to 2.4.2-pl. The upgrade progressed past the server-compatibility checklist (all green). It stopped at 'http://www.<MyDomain>/setup/index.php?action=install' with a blank screen. Subsequent refreshes of that URI also yielded blanks.

          Currently, visiting both the site's front- and back-end views produces blanks. The site is totally down.

          Error_log in the 'setup' directory has seven entries, in each of which I have disguised the actual Cpanel-account username:
          [03-Dec-2015 22:54:31 America/New_York] PHP Fatal error:  Call to a member function checkPolicy() on a non-object in /home/<CpanelUsername>/public_html/core/model/modx/modx.class.php on line 1880
          [03-Dec-2015 23:00:25 America/New_York] PHP Fatal error:  Call to a member function checkPolicy() on a non-object in /home/<CpanelUsername>/public_html/core/model/modx/modx.class.php on line 1880
          [03-Dec-2015 23:02:23 America/New_York] PHP Fatal error:  Call to a member function checkPolicy() on a non-object in /home/<CpanelUsername>/public_html/core/model/modx/modx.class.php on line 1880
          [03-Dec-2015 23:02:24 America/New_York] PHP Fatal error:  Call to a member function checkPolicy() on a non-object in /home/<CpanelUsername>/public_html/core/model/modx/modx.class.php on line 1880
          [03-Dec-2015 23:02:25 America/New_York] PHP Fatal error:  Call to a member function checkPolicy() on a non-object in /home/<CpanelUsername>/public_html/core/model/modx/modx.class.php on line 1880
          [03-Dec-2015 23:02:25 America/New_York] PHP Fatal error:  Call to a member function checkPolicy() on a non-object in /home/<CpanelUsername>/public_html/core/model/modx/modx.class.php on line 1880
          [03-Dec-2015 23:02:25 America/New_York] PHP Fatal error:  Call to a member function checkPolicy() on a non-object in /home/<CpanelUsername>/public_html/core/model/modx/modx.class.php on line 1880
          

          To anticipate questions, yes, the site does use Captcha. No, I did not disable any installed extras or delete the cache directory before running UpgradeMODX. The UpgradeMODX discussion at Bob's Guides didn't mention doing that, and besides I wanted to watch the auto-magic happen at its maximal mojo.

          I have made just the single attempt to use UpgradeMODX so as not to muddy up the picture. I want to get the site back online ASAP. So, Bob Ray, please let me know as soon as you can if you'd like to take a look at the site's files, or if I should just proceed to restore the site and manually upgrade it.
            I looked just like that in 1964.