Thank you. I appreciate to direction, however I'm kind of stuck on the webhost software (which is often buggy) until I have more energy/time to find a reliable software I can maybe one day scale up.
For now, it seems I need to make phpMyAdmin work.
Even this, after manually installing phpMyAdmin in /home/domain/public_html/phpmyadmin, shows and error on the browser with URL www.domain.com/phpmyadmin.
Error: Not Found. The requested URL /phpmyadmin was not found on this server.
[ed. note: eiger3970 last edited this post 11 years, 2 months ago.]
I'm sorry you're stuck there. It sounds like a really bad host.
Try www.domain.com/phpmyadmin/index.php
It could also be an issue with the permissions or ownership of the phpmyadmin folder.
-
☆ A M B ☆
- 1,780 Posts
Good hosting doesn't cost much at all, and even the cheapest lamest make me wanna run fast and far hosts offer some way to administer your database, typically via phpMyAdmin. You can get good MODX shared hosting for a very reasonable price. See my signature below, just for kicks and giggles and a price comparison.
Thanks.
Happy to try some hosts when I have some money.
For now, I need to use OpenSource or free services.
After some digging, I've found that
www.domain.com/phpmyadmin won't load with file /home/domain.com/public_html/phpmyadmin.
However
www.domain.com/phpsomedifferentnamemyadmin loads with file /home/domain.com/public_html/phpsomedifferentnamemyadmin.
Also,
www.domain.com/adminer loads with file /home/domain.com/public_html/adminer.
So, maybe the reason the MODX wizard failed at the install database part, is due to this webserver software blocking databases somehow?
I also changed /home/domain.com/public_html permissions to 777, but I don't think that was needed and now need to figure out how to revert the permissions back to whatever the permissions were?
I'd say that for most (but not all) hosts, the permissions should 755 for folders and 644 for files. On those hosts 777 will actually cause problems and crashed scripts.
discuss.answer
Ok, finally fixed it.
I needed to manually install an older version of phpMyAdmin.
Thanks for the help, much appreciated.
Now I can get back to the original issue, researching how to make the MODX slide manager work to show images at 100px and then use the scheduler which looks like a nice feature.