When you're back in action again, make sure that your browser cache and cookies are cleared, there might be an obsolete javascript or stylesheet stuck in its cache. Also make sure that compress_js and compress_css are disabled in System Settings, that can cause odd errors in the Manager. And delete the entire core/cache/ directory while you're at it.
Issue resolved! Turns out to be related to using < and > in the TV's "description" ... basically a no can do. I had written in the description for a couple of TVs that they were for "css inside <style>", etc. And when the manager got to that input, the description caused it to stop creating anymore TVs.