We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 44565
    • 15 Posts
    After an upgrade from 2.2.10 to 2.3.3 my editor role cannot access the file system. The behavior can be described like:

    I cannot see the file tree on the file tab and get the message Permission denied
    I can see the file browser, but get the following message: Code: 200 OK {"success":false,"message":"Permission denied!","total":0,"data":[],"object":[]}
    I can navigate through the file browser, but cannot upload any new files by using the file browser – message Permission denied

    As admin all works fine, but all users with an editor policy cannot use the file tree as aspected.

    The media sources are configured like the Creating a Media Source for Clients Tutorial on http://rtfm.modx.com/revolution/2.x/administering-your-site/media-sources/securing-a-media-source/creating-a-media-source-for-clients-tutorial.

    Any suggestions are welcome.

    Thanks & ciao
    Ralf

    This question has been answered by rwam_de. See the first response.

      • 28000 ☆ A M B ☆
      • 397 Posts
      Hi Ralf,

      I also experience permission issues when upgrading from 2.2 to 2.3. The problem was that the ACLs seemed in some cases to have changed.

      After I adjusted my permissions I created a new access policy called "Redakteur". Maybe try it out. I attached it here.

      Cheers,
      Ben
        Benjamin Davis: American web designer living in Munich, Germany and a MODX Ambassador. I am also co-founder of SEDA.digital, a MODX Agency.
      • discuss.answer
        • 44565
        • 15 Posts
        Hi Ben,

        many thanks, I've compared your policy with my permission and figured out that I must set the permission source_view to get access to the file system. Furthermore I had to set the access permissions on all of my media sources. So that the editors see the specific tree only.

        Many thanks und ciao
        Ralf