On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • After much difficulty getting Articles to work in 2.3.3, I finally elected to reinstall ModX fresh, and follow this tutorial to create my own site with several blogs using this:

    http://rtfm.modx.com/revolution/2.x/case-studies-and-tutorials/creating-a-blog-in-modx-revolution

    The snag I have hit is that the Comments Form is not even showing up, and I feel it is related to the replyResourceId. It instructs you to do the following:

    Add a "Reply to Thread" page with these snippet calls:

    <h2>Reply to Thread</h2>
    [[!Quip]]


    [[!QuipReply]]

    This is supposed to to specify a Resource ID where our Reply to Thread post is going to be.

    The question I would have for this is how do I go about creating the Reply To Thread page? What if any template should I use before adding the snippet calls to the content for it?

    Any help would be greatly appreciated, as I have posts, tvs, tags and so forth working, and comments are the last thing I need to get working to finally make some progress.

    Thanks!
    • If I understand you correctly, you need:

      Example
      myBlog.html
      [[!Quip? &tplComment=`tplComment` &threaded=`1` &replyResourceId=`200` &maxDepth=`2`]]
      [[!QuipReply? &tplAddComment=`quipAddReplyTpl`]]


      replyTo.html (Resource Id=`200`)
      // no need to call [[!Quip]] again
      [[!QuipReply]]


      Both pages can have the same template


      Demo
      http://www.leofec.com/modx-revolution/using-only-one-form-in-modx-quip-comments.html
      Blog content with regular comments, and ability to reply

      ReplyTo page returns blank with no parameters

      ReplyTo page returns form to reply to blog content
        TinymceWrapper: Complete back/frontend content solution.
        Harden your MODX site by passwording your three main folders: core, manager, connectors and renaming your assets (thank me later!)
        5 ways to sniff / hack your own sites; even with renamed/hidden folders, burst them all up, to see how secure you are not.
      • I tried this, but had three problems:

        1. Comments are still not appearing-not even a form to post a reply;
        2. I cannot determine how to set the Resource ID to 200, it created it as 5;
        3. Error Log is showing this:
        (ERROR @ /index.php) `[[+id]]` is not a valid integer and may not be passed to makeUrl()

        Here is the code I am using:

        <div class="post-comments" id="comments">[[!Quip?
        								&thread=`blog-post-[[*id]]`
        								&replyResourceId=`5`
        								&closeAfter=`30`
                                                                        &tplComment=`tplComment`
                                                                        &threaded=`1`
                                                                        &maxDepth=`2`
        								]] <br />
        								<br />
        								[[!QuipReply?
        								&thread=`blog-post-[[*id]]`
        								¬ifyEmails=`my@email.com`
        								&moderate=`1`
        								&moderatorGroup=`Moderators`
        								&closeAfter=`30`
                                                                        &tplAddComment=`quipAddReplyTpl`
        								]] </div>
        • This still did not work, so I once again attempted to use the code in the tutorial located at http://rtfm.modx.com/revolution/2.x/case-studies-and-tutorials/creating-a-blog-in-modx-revolution:

            <div class="post-comments" id="comments">[[!Quip?
                &thread=`blog-post-[[*id]]`
                &replyResourceId=`5`
                &closeAfter=`30`
              ]]
              <br /><br />
              [[!QuipReply?
                 &thread=`blog-post-[[*id]]`
                 ¬ifyEmails=`my@email.com`
                 &moderate=`1`
                 &moderatorGroup=`Moderators`
                 &closeAfter=`30`
              ]]
            </div>


          On the the reply to page, all I have is:

          [[!QuipReply]]
          <br />
          [[!Quip]]


          No reply form is appearing at all...the only thing I am still getting is this error in the error log:

          [2015-04-30 01:58:26] (ERROR @ /index.php) `[[+id]]` is not a valid integer and may not be passed to makeUrl()
          [2015-04-30 01:59:15] (ERROR @ /index.php) `[[+id]]` is not a valid integer and may not be passed to makeUrl()


          Can anyone help me out here? Articles did not work for me at all, and now I cannot get Quip to work. I really don't want to, but if I have to I will leave off comments to get my site running or use (ugh) WordPress temporarily until the new version of Flexibility comes out. Thanks for any assistance anyone might be able to provide.
          • Please update your Quip to latest version.
            ¬ifyEmails=`my@email.com` this seems dubious from the tutorial.

            To help you troubleshoot, let's format your code, if necessary type it out from scratch (avoid copy and paste).
            And let's work step by step.


            On your blog page insert this code
            [[!Quip? &thread=`article-b[[*parent]]-[[*id]]` &threaded=`1` &closeAfter=`0` &replyResourceId=`5` &maxDepth=`2`]]
            [[!QuipReply? &closeAfter=`0` &thread=`article-b[[*parent]]-[[*id]]` &recaptcha=`1` &autoConvertLinks=`0`]]

            What do you see?
              TinymceWrapper: Complete back/frontend content solution.
              Harden your MODX site by passwording your three main folders: core, manager, connectors and renaming your assets (thank me later!)
              5 ways to sniff / hack your own sites; even with renamed/hidden folders, burst them all up, to see how secure you are not.
            • Ok, Quip is running the latest, and I replaced the code I had with the sample you gave; now the comments form is appearing, and I successfully posted a comment. Definitely a step in the right direction, although I do want to make the comments moderated.

              Also, this appears above the "Add a new comment" text field:

              To use reCAPTCHA you must get an API key from http://recaptcha.net/api/getkey

              Once I get a key, where do I go to configure this?

              Thanks again for your help...I think that tutorial might have been outdated. But this absolutely helps a great deal.
              • Let's deal with recaptcha:

                In System Settings ( click the gear in MODx Manager)
                Extreme right, before, "Clear Filter", type "recaptcha" in "Search By Key".

                Look for, and fill appropriately:
                recaptcha.private_key
                recaptcha.public_key

                Does your form work as expected?


                Let's deal with moderation:

                Look in http://rtfm.modx.com/extras/revo/quip/quip.quipreply
                Consider adding these: moderate, closeAfter, moderators, moderatorGroup, notifyEmails etc.

                What is working now?
                  TinymceWrapper: Complete back/frontend content solution.
                  Harden your MODX site by passwording your three main folders: core, manager, connectors and renaming your assets (thank me later!)
                  5 ways to sniff / hack your own sites; even with renamed/hidden folders, burst them all up, to see how secure you are not.
                • Sorry to be so late in responding to this, have been dealing with family issues all week and just now getting time to sit down and work on more...the recaptcha and moderated comments are now working. THANK YOU so much for your help!!!
                  • Glad to assist.
                      TinymceWrapper: Complete back/frontend content solution.
                      Harden your MODX site by passwording your three main folders: core, manager, connectors and renaming your assets (thank me later!)
                      5 ways to sniff / hack your own sites; even with renamed/hidden folders, burst them all up, to see how secure you are not.