We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 49659
    • 86 Posts
    I installed (via Package Management) the latest version of Minishop2, which automatically installed pdoTools as well. After some experimentation, I determined that it's not exactly what we need, and so I tried to uninstall it (via Package Management).

    The process did not complete, as some files or configuration settings could not be read or removed (not sure which).

    So now, each time a web page is loaded, several errors are posted to the MODX error log, similar to these:

    [...]
    [2015-04-16 17:28:33] (ERROR @ /index.php) Could not load class: msProduct from mysql.msproduct.
    [2015-04-16 17:28:33] (ERROR @ /index.php) Could not load class: msProduct from mysql.msproduct.
    [2015-04-16 17:28:33] (ERROR @ /index.php) Could not load class: msProduct from mysql.msproduct.
    [2015-04-16 17:33:14] (ERROR @ /connectors/index.php) Could not load class: msCategory from mysql.mscategory.
    [2015-04-16 17:33:14] (ERROR @ /connectors/index.php) Could not load class: msProduct from mysql.msproduct.
    [2015-04-16 17:33:14] (ERROR @ /connectors/index.php) Could not load class: msProduct from mysql.msproduct.
    [...]

    I'm a MODX newbie, and am wondering if anyone can guide me as to what files to remove, or configuratrion edits to make, to finish the job of removing Minishop2.

    Thanks in advance,

    Karl
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      Make sure that you don't have any resources, chunks or templates with the MiniShop snippet calls. It sounds as if something like a mini-cart snippet call is still in your template somewhere.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 49659
        • 86 Posts
        Thanks. I'll poke around and see if I can find anything...
          • 49659
          • 86 Posts
          I've discovered that the errors in question:

          [...]
          [2015-04-16 17:28:33] (ERROR @ /index.php) Could not load class: msProduct from mysql.msproduct.
          [2015-04-16 17:28:33] (ERROR @ /index.php) Could not load class: msProduct from mysql.msproduct.
          [...]

          ...occur when Wayfinder is run, either like this:

          [[!Wayfinder? &startId=`[[site_start]]`]]

          ..or like this:

          [[!Wayfinder? &startId=`0`]]

          Either way, it generates a menu correctly and as expected, but these errors also appear in the log consistently, each time after clearing the cache from Manager.

          If I remove the Wayfinder code from the page, the errors do not occur. Is Wayfinder iterating through some old config data that triggers this attempted load of a missing class?

          I'm not sure how to debug this and search it out.

          Thanks in advance,

          Karl Forsyth