We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 39131
    • 84 Posts
    I've just uploaded my site from my computer to the webserver.

    When opening extra's like "SiteCheck" and "ContentBlocks" in the manager, nothing is happening.

    I see the list of all the extras, but somehow they don't open.

    Any idea what can be wrong?

    Thanks!

    This question has been answered by mewolari. See the first response.

      • 5430
      • 247 Posts
      Have you checked your error log (manager error log and server error log) and your browser's javascript console? If there aren't any significant errors in your log or console you might have a bogus cache file lingering somewhere. Be sure to clear everything in your browser cache and manually remove everything in core/cache on your server to see if that helps.
        • 3749
        • 24,544 Posts
        Did you run setup after moving the site? That will usually straighten out the paths.

        Take a look at the core/config/config.inc.php file and make sure none of the paths or URLs are pointing to the old site. In particular, look at the connectors URL.

        You can also sometimes get clues by turning on dev. tools in Chrome or FF with Ctrl-Shift-i and watching the Network tab as you try to access pages.
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 39131
          • 84 Posts
          No errors in the error-log in the manager.

          No errors during rerun of setup.

          No errors with Bob's Sitecheck.

          Saw some errors when opening Maxcdn and Contentblocks (some other extras also did not open).

          Will try if using Vapor for moving the site from my computer to the webserver is giving the same problems.





            • 5430
            • 247 Posts
            Try setting your compress_js system setting to "no" if it's current set to yes. That can cause some trouble in some hosting environments.
              • 3749
              • 24,544 Posts
              Try visiting in incognito or private mode in your browser. A bit of leftover JS or a cookie from the previous site might be confusing things.

              For now, I'd also try setting both compress_js and compress_css off.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 39131
                • 84 Posts
                Thanks for your help guys.

                I've tried several ways of installing the website.
                Zip and unzip files with ftp and sync database. Also using Vapor.
                Nothing changed. Just didn't work.

                I've also switched compress_js and compress_css off.

                Then I tried another browser. Working with OS X Yosemite 10.10.2.

                Chrome 41.0.2272.104 just doesn't work on the webserver. Using the website on my own computer (running AMPPS) and when using Modxcloud is giving no problems.

                Safari 8.0.4 however is running fine. No single problem.

                Firefox 36.0.4 is also giving problems.

                Any ideas what can be wrong?


                  • 3749
                  • 24,544 Posts
                  Browser add-ons?
                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                    • 39131
                    • 84 Posts
                    Bob,

                    I've switched off all the add-ons in Firefox. No change. Also don't understand why Modxcloud is working without that problems.

                    Was about to fully reinstall my computers. Will let you know if the problem still occurs after the fresh install..

                    • discuss.answer
                      • 39131
                      • 84 Posts
                      Guys,

                      Mark Hamstra had the solution to the problem.

                      https://support.cloudflare.com/hc/en-us/articles/200168056-What-does-Rocket-Loader-do-

                      was the cause of the problem.

                      Switching it off solved the problem

                      Thanks Mark!

                      (and of course the others for giving possible solutions!)