We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 50131
    • 8 Posts
    Hi,
    I've moved a site to a new server and can't view the content. I can login to the manager.
    I am getting the following error when the site tries to navigate to the default home friendly URL:

    Object not found!

    The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

    If you think this is a server error, please contact the webmaster.

    Error 404

    localhost
    Apache/2.4.12 (Unix) OpenSSL/1.0.2a PHP/5.6.6

    I am running MODX 2.2.7-pl and have the following components installed:
    archivist, Articles, FormIt, FormItBuilder, Gallery, getpage, getresources, quip, statcache, taglister, TinyMCE, UltimateParent, VersionX, Wayfinder

    I am a newbie.
    Any help you could provide would be appreciated.
    Thanks.
      • 3749
      • 24,544 Posts
      Here are some things to try if you haven't already:

      Run setup at the new site

      Delete all files in the core/cache directory

      Clear your browser cache and cookies.

      Make sure all your templates have this in the head section:

      <base href="[[++site_url]]" />


        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 50131
        • 8 Posts
        Thanks for your reply.
        I have tried all these things. Anything else I can try?
          • 3749
          • 24,544 Posts
          Check the rewrite base in your .htaccess file in the MODX root.

          If that doesn't work, the next step would be to begin disabling plugins, starting with StatCache.


            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
            • 50131
            • 8 Posts
            I've checked the RewriteBase in .htaccess and uninstalled every plugin, one-by-one. Still the same error.
            What am I doing wrong? [ed. note: jimzieg last edited this post 11 years, 6 months ago.]
              • 3749
              • 24,544 Posts
              Is there anything useful in the error log?
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 50131
                • 8 Posts
                Nothing, I'm afraid.
                  • 3749
                  • 24,544 Posts
                  If the Manager is working, front-end problems are almost always caused by either the .htaccess file or the base href tag.

                  Do you have more than one front-end context?

                  Are the front-end pages protected by ACL entries?

                  You might try turning off FURLs and renaming the .htaccess file to see if it makes a difference.

                  Can you reach the home page by just going to yoursite.com?
                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                    • 50131
                    • 8 Posts
                    I'll have a look. [ed. note: jimzieg last edited this post 11 years, 6 months ago.]
                      • 50131
                      • 8 Posts
                      Quote from: BobRay at Mar 24, 2015, 11:48 PM
                      If the Manager is working, front-end problems are almost always caused by either the .htaccess file or the base href tag.

                      Do you have more than one front-end context?
                      No.
                      Quote from: BobRay at Mar 24, 2015, 11:48 PM

                      Are the front-end pages protected by ACL entries?
                      No.
                      Quote from: BobRay at Mar 24, 2015, 11:48 PM

                      You might try turning off FURLs and renaming the .htaccess file to see if it makes a difference.
                      It did nothing.
                      Quote from: BobRay at Mar 24, 2015, 11:48 PM

                      Can you reach the home page by just going to yoursite.com?
                      No, it just shows the folder in which the site resides.