We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 50050
    • 10 Posts
    Hey Guys,
    I hope that experienced guys here will be able to help me with this issue. Im more than happy to pay to developer that will resolve it for me.

    I am a front end Dev and made this site a couple of weeks ago: http://www.kitchencraftsmen.com.au/
    As they are a medium business they at the moment having a big marketing campaign so the pressure is on.

    Going ot my caching issue, after the transfer to new server - im having cache errors....
    [2015-03-23 10:43:17] (ERROR @ /connectors/lang.js.php) Error caching action map mgr/actions

    This one is not worry me but sometimes im getting : (ERROR @ /index.php) Could not cache resource 1
    which is breaking the site displaying a blank page, the resource is random each time, and I have no idea, how to fix it.

    Already tried to gogole it and actions ive took already:
    1. reupload the core, connectors, files
    2. reupload the setup files and actioning the install
    3. Ive changed permissions to cache folder to 755 and files to 644 via ftp


    Is there anything else I should do?
    thanks

      • 10208 ☆ A M B ☆
      • 1,780 Posts
      Have you deleted all the files in the core/cache folder?

      If not, do that. If it doesn't work, don't upload selective files, but fetch a nice fresh copy of the modx-yourVersion.zip and make sure to upload the zip file to the server and unpack it into it's own folder in the file manager. Don't FTP an unpacked folder, too many possible errors.

      Re-run setup in update mode with all of the new MODX files copied/moved/merged.

      Too many times I've messed with things for hours, and found the solution to be a fresh full copy of MODX. At least then you'll know if that was the problem, and it's easy to try.


        Frogabog- MODX Websites in Portland Oregon
        "Do yourself a favor and get a copy of "MODX - The Official Guide" by Bob Ray. Read it.
        Having server issues? These guys have MODX Hosting perfected - SkyToaster
        • 47401
        • 295 Posts
        i had a similar problem ages ago. I downloaded the exact version of the installed modx. copied the setup folder to the root and re ran setup with the update option. the problem with FTP is that it isnt reliable. files can be skipped or become corrupt. its best to do this in command line rather than relying on ftp software.