New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • distant_smile Reply #1, 4 years ago
    Hi,

    I have run the following snippet:

    [!AjaxSearch? &ajaxSearch=`0` &ajaxSearch=`0` &showIntro=`0` &showResults=`0` &landingPage=`9` &advSearch=`allwords`!]


    And my landing page has this snippet call:

    [!AjaxSearch? &ajaxSearch=`0` &parents=`4` &tvPhx=`legoImages` &whereSearch=`content` &order=`pagetitle` &extract=`2:longtitle,introtext` &showPagingAlways=`1`!]


    My TV has a value of `image` and is named legoImages. The results when called return a pagetitle and summary, but the image appears as a tiny empty square. Looking at the page source it shows
    <img src="" height="" />
    


    I have amended result.tpl to:

    <div>
    <a href="[+as.resultLink+]" title="[+as.longtitle+]">[+as.pagetitle+]</a>
    <div>
    <img src="[+as.LegoImages+]" height="[+as.legoImages:imgmaxheight=`120`+]" />
    </div>
    [+as.extractShow:is=`1`:then=`
    <div><p>[+as.extract+]</p></div>
    `+]
    [+as.breadcrumbsShow:is=`1`:then=`
    <span>[+as.breadcrumbs+]</span>
    `+]
    </div>


    My search results dont appear to pull the image in? Can anyone see any obvious mistakes?
    Regards,
    SB [ed. note: distant_smile last edited this post 4 years ago.]
      www.PawsForWildlife.co.uk
      www.Borntobrick.co.uk
    • distant_smile Reply #2, 4 years ago
      Solved! I used 'LegoImages'. The word lego was supposed to all be in lower case
        www.PawsForWildlife.co.uk
        www.Borntobrick.co.uk