I have installed MODx Revo v2.3.3 on an IP address for now as the domain name is not yet ready to be pointed. During installation everything seemed to be seemless including all the checks were green. I was able to log into my control panel and the news feeds (MODx News Feed, Who's Online, MODx Security Feed, and Critical Login) all show fine.
My problem is when I click just about any link in my control panel, the white content area of most pages are blank. The only thing that shows is the admin bar on top.
Here is a sample URL that shows a blank page: http://MyServerIPAddress/~MyCpanelUsername/manager/?a=system/settings
I have installed MODx in the past (past versions of MODx) with my server IP address and CPanel Username with no issues. But this time it seems like my admin pages are not loading properly.
I have installed, deleted, and re-installed again. The same issue persists. That is most of my admin panel areas provide blank white pages with just the control panel. Don't know what to check to fix this issue. Please help.
This may be an issue with your host. Are you also getting to a point where nothing loads? On my site that had issues, they indicated that too many requests were being made to the database, and the site was getting temporarily blocked. The block would only last for a few minutes. Too considerable phone calls to resolve, and in the end — MODx does now function, but I have no idea what exactly was done on their end to resolve the issue. All future MODx installs are being hosted elsewhere.
If the admin bar is showing, do you have access to the error reports? I'd check that if possible, and also check your browser's console for any javascript errors. You can also check your server's error log. Somewhere there's a record of what's going wrong.
Quote from: mmcgee at Mar 12, 2015, 01:33 PMThis may be an issue with your host. Are you also getting to a point where nothing loads? On my site that had issues, they indicated that too many requests were being made to the database, and the site was getting temporarily blocked. The block would only last for a few minutes. Too considerable phone calls to resolve, and in the end — MODx does now function, but I have no idea what exactly was done on their end to resolve the issue. All future MODx installs are being hosted elsewhere.
I have a reseller account through Host Gator and have about 10 sites running MODx successfully. All of them installed without a hitch including the one in the past that I set up with an IP address for domain name. That was a few years so maybe something changed. Maybe something has changed with them.
I am able to login to admin with no issues. But only the top admin bar shows on most links from inside the control panel. The help page, and the admin main pages laod just fine, but if I click on any other links the URL in admin changes, but the main part of the page is blank.
A few of the links like: Manage> flush your permissions and Mange>flush cache do not seem clickable. I diabled all pop-up blockers like Adblock plus just in case.
Quote from: claytonk at Mar 12, 2015, 01:59 PMIf the admin bar is showing, do you have access to the error reports? I'd check that if possible, and also check your browser's console for any javascript errors. You can also check your server's error log. Somewhere there's a record of what's going wrong.
No the: manage> reports> error log shows a blank page. Can I donwload it directly via FTP to view?
Hmmmm. I think my temporary IP address string: http://MyServerIPAddress/~MyCpanelUsername/manager/?a=system/settings
is causing the issue. Notice the (~) before my CpanelUsername?
My host says if it installed properly it should work, but he admitted that he knows nothing about MODx. So they don't know what to tell me.
I think I will have to install on a sub-domain (no IP adress and crazy characters in domain name) and then move over to live site later. Sometimes, I wish it was easer to build a live site without domain name and just switch. But its never that easy.
Ok Modx installed nicely on my subdomain. Another thing that was missing from the IP address installation was the files manager on the left hand side. Even when the news feeds were showing the file manager was nowhere to be seen.
Anyway, I suppose for future test installations it might be best to use a resolved subdomain. Thank you for your help.