I have tried both
Interestingly, I logged back in today, and one of them is saved.
However, when I look in the DB, I see this:
a:3:{s:8:"basePath";a:6:{s:4:"name";s:8:"basePath";s:4:"desc";s:23:"prop_file.basePath_desc";s:4:"type";s:9:"textfield";s:7:"options";a:0:{}s:5:"value";s:16:""
assets/images/"";s:7:"lexicon";s:11:"core:source";}s:7:"baseUrl";a:6:{s:4:"name";s:7:"baseUrl";s:4:"desc";s:22:"prop_file.baseUrl_desc";s:4:"type";s:9:"textfield";s:7:"options";a:0:{}s:5:"value";s:14:
"assets/images/";s:7:"lexicon";s:11:"core:source";}s:15:"imageExtensions";a:6:{s:4:"name";s:15:"imageExtensions";s:4:"desc";s:30:"prop_file.imageExtensions_desc";s:4:"type";s:9:"textfield";s:7:"options";a:0:{}s:5:"value";s:20:"jpg,jpeg,png,gif,psd";s:7:"lexicon";s:11:"core:source";}}
It looks like the path IS actually being saved in the db even though it doesnt show in the admin. Unfortunately, it doesnt show in the admin, and more importantly, when I go to the Media Browser, there were no images in there, even though I can see many images in there on the server.
When I try uploading an image, I got:
The specified directory is not a directory.: /home3/username/public_html/"assets/images"
I tried single, double, and no quote marks in that db field. Removing quote marks fixed it, but I had to delete cache, so this could be all caused by caching issues.
But, then i have a new issue. The thumbnails are all broken, so I try visiting one of the image thumbnail paths (not sure if this should work):
http://www.example.com/connectors/system/phpthumb.php?src=neck_brace.jpg&w=100&h=80&f=png&q=90&far=1&HTTP_MODAUTH=modx5424ecd87e8020.21199023_15500f11c8f1514.96111491&wctx=mgr&source=2
and it shows
Notice: unserialize(): Error at offset 152 of 637 bytes in /home3/john/public_html/core/xpdo/om/xpdoobject.class.php on line 1061
Notice: unserialize(): Error at offset 152 of 637 bytes in /home3/john/public_html/core/xpdo/om/xpdoobject.class.php on line 1061
Notice: unserialize(): Error at offset 152 of 637 bytes in /home3/john/public_html/core/xpdo/om/xpdoobject.class.php on line 1061
Notice: unserialize(): Error at offset 152 of 637 bytes in /home3/john/public_html/core/xpdo/om/xpdoobject.class.php on line 1061
‰PNG IHDRd9ÀòŽ}gAMA±üasRGB®Îé cHRMz&€„ú€èu0ê`:˜pœºQ<�bKGDÿÿÿ ½§“ pHYsÊ&ó?5ÃIDATxÚU¼YŒeYvž÷íáŒwŠsäÃÕU’´ÃþÞ‡”Å/%Ö{ÔÅkW†è¥4HÁôãv¼ðhˆÓ¤ý<®µ&µâ6”Ä9‡÷þÔ ¬µ q–’¤1J ¸Ó4˜Æ€÷D‘B IÇdY‚Vš¦qÌæ5ee)– uã¢]´àÕÂúã‘´VJ:¼7x»Ä˜‚E±À#™.f,ªš¼;^@€R1B(¬©p%J4ª=t¦.................etc....
I really cant afford to upgrade. It cost me way too much to upgrade to my current version. I often miss Wordpress at times like this. Besides, generally speaking, the newer and more complex a software platform is, the more likely something will break, and harder to fix.