I'm running two different installs of Revolution 2.3.1 and I'm having a problem that is driving me nuts. It may not be Modx related but I hope someone could shed some light. I installed a jQuery plug-in for currency conversion. On website A, it's working great. On website B, it's not running.
I checked the console and a JS file and a CSS file that is needed for the plug-in cannot be found. The files are there, the folder is permissions 755 and the two files are 644. The settings are exactly the same on both sites but the files cannot be found on one of them.
Could anyone shed some light? How can a JS or CSS "file not found" error occur when the files are indeed there and readable? There must be a logical explanation.
I can only think of four possible explanations:
- The URLs of the files are wrong (remember that they're URLs, not file paths)
- The URLs are relative (not full) and the base href tag in the head section of the template is wrong or missing
- Your using regClient*() to load them and the template has no head section.
- The ownership of the files doesn't allow them to be read
-
☆ A M B ☆
- 24,524 Posts
Your home page is reloading because it's your not-found page. You should always create a dedicated not-found page, and set the error_page in System Settings to use it.
In that case, it almost has to be file permissions or ownership.