We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 49801
    • 3 Posts
    Ciao a tutti , sono una new entry. Da pochi giorni sto cercando di utilizzare questo fantastico cms. Purtroppo sono al mio primo intoppo , il menù con Wayfinder.
    Questo è il codice Html del mio menù :
    <nav id="nav-container">
    					<ul>
    						<li><a href="#">Hello</a>
    							<ul class="sub-menu">
    								<li><a href="index.html">Index Fullscreen</a></li>
    								<li><a href="index-corporate.html">Index Corporate</a></li>
    							</ul>
    						</li>
    						<li><a href="services.html">Services</a></li>
    						<li>
    							<a href="#">Portfolio</a>
    							<ul class="sub-menu">
    								<li><a href="portfolio-grid.html">Portfolio Grid</a></li>
    								<li><a href="portfolio-masonry.html">Portfolio Masonry</a></li>
    								<li><a href="portfolio-projects.html">Portfolio Projects</a></li>
    							</ul>
    						</li>
    						<li>
    							<a href="#">Portfolio Single</a>
    							<ul class="sub-menu">
    								<li><a href="portfolio-single-slider.html">Single Slider</a></li>
    								<li><a href="portfolio-single-images.html">Single Images</a></li>
    							</ul>
    						</li>
    						<li><a href="about.html">About</a></li>
    						<li><a href="contact.html">Contact</a></li>
    					</ul>
    				</nav>


    Ovviamente con i miei vari tentativi ho ottenuto solo menù invisibili smiley . Aspetto un vostro prezioso aiuto

    This question has been answered by ottogal. See the first response.

    • discuss.answer
      • 22427
      • 793 Posts
      Per potere aiutarti c'è bisogno di più d'informazioni.
      Qual'è la tua chiamata di Wayfinder? Com'è l'albero delle risorse?
      Ai in uso i FURL? E, prima di tutto: Revo o Evo?
        • 49801
        • 3 Posts
        Ciao ottogal e grazie mille per il tuo intervento.
        Effettivamente avevo il sospetto di non essere stato esaustivo smiley , riparo subito:
        1)Allora, prima di tutto sono riuscito a risolvere il problema del menù , "inesistente" reinstallando wayfinder (ora mi compaiono almeno le voci del primo livello, ora resta da risolvere il problema del sub-menu )
        2)Uso revolution e non ho in uso Furl
        3)La mia chiamata è questa:
        <nav id="nav-container">
        				 [[Wayfinder?
        		&startId=`0`
        		&level=`2`
        		&rowTpl=`rowTemplate`
        		&innerTpl=`innerTpl`
        	  ]]
        					
        				</nav>


        Mentre questi sono i rispettivi chunk

        rowTemplate:
        <li><a href="[[+wf.link]]" >[[+wf.linktext]]</a></li>


        innerTpl:
        <ul class="sub-menu">
        [[+wf.wrapper]]
        </ul>


        Inoltre nel caso riuscissi a far comparire le voci del secondo livello , ci sarà il problema che alcune voci saranno solo dei contenitori (cioè link non cliccabili, come nello screen allegato la voce "portfolio").
        In realtà dopo centinaia di ricerche ho trovato, alcuni escamotage usati con altri moduli , dove inserivano un "Attributo Link" e dichiaravano nel chunk la non cliccabilità del link,
        Questo è il codice trovato :
        <li[[*id:is=`[[+id]]`:then=` class="active"`]]>
            [[+link_attributes:isnot=`nolink`:then=`
                <a href="[[~[[+id]]]]">
            `:else=`
                <a>
            `]]
            [[+menutitle:default=`[[+pagetitle]]`]]
            </a>
            [[[[+level:lt=`[[+maxLevel]]`:then=`getResources@main-menu? &parents=`[[+id]]` &level=`[[+level:add]]``:else=`-`]]]]
        </li>

        Ma non avrei idea di come usarlo con wayfinder .

        Spero di essere stato chiaro , a presto.
          • 22427
          • 793 Posts
          To display the submenus, you need to add [[+wf.wrapper]] also in the rowTpl:
          Per far comparire anche i submenu bisogna aggiungere [[+wf.wrapper]] anche nel rowTpl:
          <li><a href="[[+wf.link]]" >[[+wf.linktext]]</a>[[+wf.wrapper]]</li>
          [ed. note: ottogal last edited this post 9 years, 3 months ago.]
            • 22427
            • 793 Posts
              • 49801
              • 3 Posts
              Grazie mille ottogal wink ora funziona... devo solo risolvere al meglio il problema del "nolink" ora le provo tutte