We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36788
    • 75 Posts
    After upgrading to modx 2.3.3 can't get to manager panel. The first time everything was ok, but on second login I get an an error:Fatal error: Maximum execution time of 30 seconds exceeded in C:\wamp\www\trevo.ru\manager\controllers\default\dashboard\widget.modx-security.php on line 17

    I'm working on local machine and was able to changed the max_execution_time to 360 and it solved the problem though on my shared hosting the Maximum execution time is 30 seconds are there any workaround to solve this?
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      You can disable those feeds in the system settings, or even in the system_settings table in the database.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 36788
        • 75 Posts
        Here is the code which is leading to the error:
              
         if (function_exists('checkdnsrr') && !checkdnsrr('google.com', 'ANY')) {
                    return '';
                }
        


        Can this be done via ajax instead of php script to not causing an error on login?
          • 36788
          • 75 Posts
          Quote from: sottwell at Feb 01, 2015, 08:19 AM
          You can disable those feeds in the system settings, or even in the system_settings table in the database.

          Thank you! Will turn it off if will not find a better solution. Though this is how I'm getting the news about modx, so don't want to turn it of ))
            • 28042 ☆ A M B ☆
            • 24,524 Posts
              Studying MODX in the desert - http://sottwell.com
              Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
              Join the Slack Community - http://modx.org
              • 36788
              • 75 Posts
              I tried to turn off the RSS and News but it doesn't help.

              Though if i comment the lines
                     /* if (function_exists('checkdnsrr') && !checkdnsrr('google.com', 'ANY')) {
                          return '';
                      }*/


              in widget.modx-news.php and widget.modx-security.php it solves the problem and manager panel loads very fast

              I must add that I'm working on local server running with wamp.
                • 2282
                • 17 Posts
                I'm having the exact same issue (with the same temporary solution, i.e. commenting) while using xampp on windows 7 machine. (2.3.3-pl, advanced)

                I've run the same process on a hosted server (linux) and everything works fine, so this really seems to be tied to windows OS.
                  Have no way as way, have no limitation as limitation
                  • 10891
                  • 7 Posts
                  Quote from: Askarii at Apr 12, 2015, 05:20 PM
                  I'm having the exact same issue (with the same temporary solution, i.e. commenting) while using xampp on windows 7 machine. (2.3.3-pl, advanced)

                  I've run the same process on a hosted server (linux) and everything works fine, so this really seems to be tied to windows OS.

                  checkdnsrr()

                  5.3.0 This function is now available on Windows platforms.