We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36782
    • 109 Posts
    [UPDATE: had posted 'advanced' however it seems it is like this on standard installations too... sad
    I've updated the title to reflect this fact.]

    Hi,

    I'm running advanced, and standard installs of 2.2 on cloud linux Cpanel (greengeeks). I've got several working 2.2 installations running on this hosting no problems.

    When I updated to 2.3, on both standard and advanced sites I could no longer install extras. I'm getting some kind of EXT error. From Chrome console:


     XHR finished loading: POST "http://jh.ca/connectors/index.php".
    ext-base.js:21 XHR finished loading: POST "http://jh.ca/connectors/index.php".
    

    ...as you can see, working fine for manager, including re-installation of existing extras.
    ext-base.js:21 POST http://jh.ca/connectors/index.php 404 (Not Found)
    ext-base.js:21 XHR finished loading: POST "http://jh.ca/connectors/index.php".
    modx.window.js:60 Uncaught TypeError: undefined is not a functionmodx.window.js:60 Ext.override.onShowext-all.js:21 Ext.Window.Ext.extend.afterShowext-all.js:21 Ext.Window.Ext.extend.showext-all.js:21 Ext.MessageBox.showmodx.js:116 Ext.extend.onAjaxExceptionext-all.js:21 h.Event.fireext-all.js:21 h.Observable.fireEventext-all.js:21 Ext.extend.handleFailureext-base.js:21 fext-base.js:21 mext-base.js:21 (anonymous function)
    onew.png:1 GET http://jh.ca/assets/tpl/jennifer/img/onew.png 404 (Not Found)

    ...and that's what happens when I try and update, or install a new extra.
    And the screen gets all hinky and offset, so that the menu disappears and I have to refresh.

    Anyone seen anything like this?

    This question has been answered by unsub777. See the first response.

    [ed. note: unsub777 last edited this post 11 years, 7 months ago.]
      • 28042 ☆ A M B ☆
      • 24,524 Posts
      Sounds like what happens when the MODX repository's server is down.
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 28042 ☆ A M B ☆
        • 24,524 Posts
        On further though... did you make sure your browser's cache was cleared? Sometimes the old javascript gets stuck in the browser cache. Also make sure to delete the core/cache/ directory.
          Studying MODX in the desert - http://sottwell.com
          Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
          Join the Slack Community - http://modx.org
          • 36782
          • 109 Posts
          Hi Susan,

          Thanks - I should have given more info, I think.

          I have cleared cache, both in manager, as well as on the server directly.

          Unfortunately, no - not a repo issue, as I have had this since 2.3.0 when I did my first site update from 2.2x

          I've just contacted my host to see if there's a mod_security error being thrown, maybe they can enlighten me because I've come very quickly to the end of my ideas on this one. No errors in error log, either in manager or cpanel, and the 404 is obviously erroneous... baffled. LOL

          Anyway, I'll update if I get anywhere with my web host.

          cheers
          • discuss.answer
            • 36782
            • 109 Posts
            Hi.

            Just an update on this:
            My host, Greengeeks, looked at the mod_security errors for me, and were able to disable a particular rule - in my case, 340162.
            I cleared both my modx cache and also my browser cache, et Voila! My package management works smiley

            Thanks