On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hi Guys,
    I moved my Modx Revo 2.3.2 install to a new server and now the Article extra does not populate the rows in the manager. See attached.
    I have curl and APC installed and also tried disabling css and js compression in system settings?
    Any ideas? See attached.
    Thanks
    • Could you tell us more about your hosting environment?
        Patrick | Server Wrangler
        About Me: Website | TweetsMODX Hosting
      • Solved. Looks like having curlssl installed rather than curl caused the issue. Also APC needs to be installed to server.
        • I'm glad to hear you resolved the problem, thanks for sharing the solution.
            Patrick | Server Wrangler
            About Me: Website | TweetsMODX Hosting
          • I also have the "no rows" problem with Articles after recently test-migrating to MODx Cloud. The Articles version is 1.7.10-pl and the MODx version is the most recent.
            The problem is not that the articles are gone, but that I can't see any articles in my Article-container (I can see the number of pages though). I can't migrate this client to MODx Cloud untill Articles is working properly.

            Please reply if anyone has a solution to this problem.

            Regards

            rich [ed. note: rich last edited this post 4 years, 2 months ago.]
            • Weird particularly because everything used to work for me in the modx cloud hosting. I reckon deleting the core/cache folder entirely and creating a new one with 777 permissions is all I can think of. Maybe disable css and js compression too in the system settings. Yes articles is a pain but did work on modx cloud. Try also with different browsers. I see a lot of strange caching these days.
              • Thanks for the reply howster. I have checked my settings just now and css and js compression was already disabled. What is strange is that I have another site in the MODx Cloud where I installed articles just to test, and it seems to be working good there; so the problem here seems to be caused from upgrading.

                One thing:
                The MODx version of the site I imported into the cloud was version. 2.2.13-pl, and the Articles version was 1.7.6-pl.

                What I did was the following:
                1. Making a dump of the site using Vapor. MODx version 2.2.13-pl, Articles version 1.7.6-pl.
                2. Imported the snapshot into MODx Cloud (Create new cloud from snapshot).
                3. Used the "Reinstall Product" function in the Cloud interface.
                4. Logged into the manager of my newly imported site.
                5. Upgraded articles.

                Everything else is working perfectly, but Articles is acting up.
                • I go back to basics when I start getting weird results. Quite often its a corrupt upload. I'd just delete cache, clear sessions and flush permissions and zip everything up on the working site, download it and ftp it up to the modxcloud hosting using filezilla or something and extract using some ssh console like Putty to make things quicker. Double check with modxcloud support that your htaccess equivalent rules for nginx are correct. As they use nginx there's particular rules being implemented to achieve the htaccess equivalent on apache. Particularly if you use a subdirectory installation. Modxcloud also use a weird server path so check it all out preinstallation using a phpinfo file. Use phpinfo to ensure curl and APC are installed. Definutely involve modxcloud support though. That's what I'd do.
                  • Thank you howster, I will try a bit more for myself; and if that doesn't work I will contanct MODx Cloud support. I will post the solution to the problem here when I find it.

                    Cheers smiley