We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 43280
    • 15 Posts
    I have recently run into severe problems with modx 2.3. Ive been using modx on a few sites some tied to my personal shared hosting plan (thiswebhost) and with another for a clients shared plan with a different provider (lithium hosting)


    the general stats in cpanel for the Lithium Hosting shared hosting account:

    OS: Linux
    Apache Version 2.2.29
    PHP Version 5.4.36
    MySQL Version 5.5.40-cll



    And the stats with my other account (thisWebHosting) cpanel:

    OS: Linux
    Apache Version 2.2.27
    PHP Version 5.3.29
    MySQL Version 5.5.40-cll




    All these sites were functioning quite well with various versions of modx 2.2-2.3. Recently going through my rounds of keeping the websites up-to date i noticed there was a new version of modx (2.3.2) so i backed up all sites via softalicious and proceeded to upgrade.


    Now Im having all sorts of issues and reverting back to my backups is not solving the issues.


    ThisWebHosting: these sites are working fairly well except I cannot install any packages in extras package manager. I can see popular packages, pick one, download it...but when I start the installation the console just sits there and never installs. I have reverted the sites back to older backups and the problem persists. I checked the console in the browser and there is a 403 forbidden error popping up And im not sure if it has anything to do with it.



    Lithium Hosting: This one site has the same issue as above, but it also has some of the "missing elements" in the manager. I've been digging in the forums all day and have tried all the recurring troubleshooting suggestions, most notably deleting the cache and disabling js/css compression. and while this got some elements to show up they don't always show up and there are a lot of internal server errors (500) in the inspector console in chrome. this is with both a fresh installation via softalicious and a manual install with the 2.3.2 pl zip.



    I'm not the most knowledgable person when it comes to these server based issues, and Im stuck on what to do/try next. I am assuming i can try tech support for the hosting companies to see if they have changed something that is causing the problems, but I don't know exactly what to ask them to check for.



    so here are my questions:

    Does this seem like server changes on my hosts' end versus an issue with modx itself? It's weird because Im having issues with both hosting providers who have within the span of the last two years have never had issues with running modx revo.

    Is there any other troubleshooting I can try? At this point I've backed up all my files and am ready to clear everything and setup all the files again if i can get everything (including extra package installations) to work. Ive checked that the packages I have tried installing to the best of my knowledge are compatible with 2.3.2 (Articles, Formit, wayfinder, etc)

    If its something with the hosting, any tips/info on what to refer to them? anything I need to say or ask them to check on?

    Thanks and hoping I can get this sorted as these hosts have up until now been rock solid with modx and I cannot look for other hosting at this time so it'd be a bummer to give modx up and settle for something like wordpress ;_; ...Any help would be greatly appreciated. If theres any other information I can/need to provide I can.

    This question has been answered by wonderfulweb. See the first response.

      • 36926
      • 701 Posts
      Have you check all the correct directories have the correct read and write permissions. Can'r remember off hand the list but sure it's on the rtfm.

      Also did you say you've tried a complete fresh install on the server. I can't imagine there be much thats changed in 2.3 to have server issues. So far the only issues i've had have been extras themselves and not the environment. But not used the hosts in question before.

      When you say some extras show up and some don't is the manager working as expected and what extras are causing issues.

      Have you had any luck with get the site upgraded and working locally?

        • 43280
        • 15 Posts
        Quote from: bennyb at Jan 26, 2015, 06:42 PM
        Have you check all the correct directories have the correct read and write permissions. Can'r remember off hand the list but sure it's on the rtfm.

        Also did you say you've tried a complete fresh install on the server. I can't imagine there be much thats changed in 2.3 to have server issues. So far the only issues i've had have been extras themselves and not the environment. But not used the hosts in question before.

        When you say some extras show up and some don't is the manager working as expected and what extras are causing issues.

        Have you had any luck with get the site upgraded and working locally?



        I'm gonna try to check all the permissions here shortly. Ive briefly looked at file permissions but maybe havent done a good enough job since i tried upgrading etc.

        I have never setup modx locally, but was actually thinking of doing that soon just to see. Seems like a good idea to get some more info about what I'm missing. Will add that to my to do list if I dont figure out the problem soon.


        As far as i can tell, all the extras like Articles, etc are working, I can see the files and snippets and such, the functionality is there....It is only the installing/updating that doesn't work, and gives me a weird 403 forbidden error in chrome console when i try to install or update a package in package manager. (references connector/index.php) Which definitely means it could be I've done something to the heiarchy of permissions or something else.

        I'll look into the file permissions stuff and then perhaps try a local setup and see how it goes...I havent really messed with the backed of these sites in months so im really lost as to where the problem lies. I'll keep trying stuff and update if I find anything.
          • 28042 ☆ A M B ☆
          • 24,524 Posts
          Odd errors in the manager like that can crop up when the server's mod_security rules are updated. Usually these are pre-packaged lists of generic rules, and there can be hundreds if not thousands of them.

          The MODX Manager uses a lot of AJAX requests, and in some cases there are too many requests from the same IP address over a short period of time, causing some of them to be refused. This can cause unpredictable failures of different parts of the Manager.

          In other cases, in fact one I just ran into the other day, a simple snippet save of a snippet I use on almost every site I build, including several on this same hosting provider, was refused because the AJAX request didn't have certain HTTP headers, causing a PHP fopen() function reference to be denied. If something like this is causing your problems, the hosting provider has to disable these mod_security settings for your site.

          The hosting provider can look at his mod_security logs to see exactly which rules are causing failures.
            Studying MODX in the desert - http://sottwell.com
            Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
            Join the Slack Community - http://modx.org
          • discuss.answer
            • 43280
            • 15 Posts
            Okay some updates:


            The site that is on Lithium hosting seems to be working okay now. Perhaps it was just something that was a hiccup, so I'm leaving that alone and I'll submit a ticket if the issues come back.


            On my personal account (thisWebHost) I found an old thread where a guy had a similar problem related to mine, and in the thread an .htaccess rule was found to alleviate blocks without having to deal with mod_security. (for shared hosting plans likes mine)

            i put this code from that thread in a .htaccess file in my connectors folder:

            <IfModule mod_security.c>
            SecFilterEngine Off
            SecFilterScanPOST Off
            </IfModule>



            (that thread is here https://forums.modx.com/thread/70462/403-forbidden-on-connectors-resource-index-php)


            and voila! i was installing extras again! I seem to have some issues with articles not showing up as a resource type, but I think thats another issue outside the realm of this thread. If i get more issues related to this I'll consult my hosting about it. It probably does have to do with certain rules or server issues. Thanks for the replies and guidance it really helped. Going to mark this as "solved"