We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 27330
    • 884 Posts
    Hi all,
    I've updated a site to latest 2.3.2 and now I'm getting similar errors when updating packages or deleting site cache:
    PHP warning: unlink(/usr/local/www/domain.com/core/cache/lexicon_topics/lexicon/en/cronmanager/default.cache.php): Permission denied
    PHP warning: closedir(): 31 is not a valid Directory resource
    PHP warning: unlink(/usr/local/www/domain.com/core/cache/scripts/elements/modsnippet/24.cache.php): Permission denied
    PHP warning: closedir(): 36 is not a valid Directory resource
    PHP warning: unlink(/usr/local/www/domain.com/core/cache/includes/elements/modsnippet/24.include.cache.php): Permission denied
    PHP warning: closedir(): 41 is not a valid Directory resource


    I have ran
    chmod -R 777 cache/
    on the folder and error persist.

    any ideas?
      • 3749
      • 24,544 Posts
      Try 755.
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 27330
        • 884 Posts
        Thanks Bob, tried that but the result is a blank manager page, had to revert back to 777.
        If I recall correctly in Evo we needed to set different permissions for the folder and sub file/folders. is this the case here as well maybe?

        the system is FreeBSD 10.1-RELEASE btw.
          • 3749
          • 24,544 Posts
          It could be a problem with the ownership of the files.

          I know some people have reported similar issues that turned out to be mod_security violations.

          It's also possible that one or more files got missed or corrupted in the transfer or that some new files failed to overwrite the old ones. This is common if you use FTP to transfer them individually.

          One quick test: try it as a sudo user. If that solves it, it's an issue with your permission settings.

          You might also check the paths and URLs in the core/config/config.inc.php file (or run SiteCheck, which will check both the file and directory permissions, and the paths and URLs in the config file).

            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting