On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hi there,

    i can't install modx on a single server. It is a shared hoster with plesk as configuration tool. The hosting configuration is shown in the image attached. Here are some infos:

    • MySQL Server Version: 5.1.73
    • PHP Version 5.3.3
    • Server API CGI/FastCGI

    I've uploaded the modx package to the server with a ftp client and started the setup. The welcome page and the language selection worked. But the options page (/setup/index.php?action=options) is blank. When I manually go to the next page (/setup/index.php?action=database) I'm able to carry on with the installation process and install the databes etc. But the Manager Page and the installation success page are blank. But the database is installed.

    Someone who can help?

    Best regards, Björn

    This question has been answered by winfomatic. See the first response.

    • Björn,

      This all depends if your FastCGI is running Apache as the user, or apache itself. These two are user accounts and require writing permissions to perform the installation.

      I'm going to assume you're working with a standard installation and you've unzipped all the files in the htdocs/public_html/documentroot.
      Always make sure the following folders (unfortunately by head, might be forgetting some) exist and are writable.

      assets/components/
      core/cache/
      core/components/
      core/import/
      core/export/
      core/packages/
      core/config/ (or core/config/config.inc.php)

      Try that as a first, and if your setup still returns a blank page, clean up core/cache/logs/error.log, rerun the setup again, hit the same blank page and post the contents of that error.log file in the forums. smiley
        @MarkGHErnst

        Developer at Adwise Internetmarketing, the Netherlands.
      • Hi, thanks for your reply.

        All these folders exist and have write permissions. I unzipped the install package to a subfolder of the root (ftp path = /html/modx/... and server path = /var/www/vhosts/domain.tld/html/modx/...). But the domain is directly mapped to the subfolder. So the domain "mycooldomain.tld" is linked to "/html/modx/".
        I also thougth it is a write permission problem and gave every folder and file the chmod 0777 permission (just for testing). Nothing changed. Still a blank page at the third install step...
        When the blank page at the third setup step is displayed, no log file is created in the log path.


        UPDATE: I found out, that I get an 500 HTTP Error when I'm proceeding to step 3 (options) of the installation process...


        Best Regards,
        B.
        [ed. note: winfomatic last edited this post 6 years, 9 months ago.]
        • discuss.answer
          I GOT IT smiley

          I uploaded the Installation files through the Plesk-Web-FTP-Filemanager and unzipped them. Now the files have another user (chowner) and suddenly everything works?!

          Summary for my host:
          Wrong: uploading files (one by one) with filezilla
          Right: uploading files (zipped) with the web filemanager and unzip them on the server.

          Maybe this helps someone else smiley