On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • For whatever reason, when using CKEditor in MODX (Revolution 2.3.2-pl (traditional) and using CKEditor (ckeditor-1.3.0-pl) from modx.com provider, double quotes " " are translated to « and ». Is anyone else experiencing this problem? Attached is a screenshot of the system settings for ckeditor.autocorrect_single_quotes and ckeditor.autocorrect_double_quotes to show they are set correctly (I think).

    The whole reason we're using CKeditor instead of TinyMCE is because we wanted to hide the view source button from the publishers. So my questions are these...

    1. Has anyone encountered and fixed the « » issue?
    2. Is there a way to hide the view source toggle in TinyMCE in order for us to switch away from CKEditor?

    Thank you for any help. [ed. note: zensmile last edited this post 5 years, 9 months ago.]
    • In the top row of the CKEditor, just to the left of 'ABC' is the 'AutoCorrect'.

      - Click on the icon to get the 'Options' menu
      - Click 'Auto Format As You Type' and uncheck the 'Smart Qoutes' option
      - Do the same in the 'Auto Format' tab
        Michael Regan
        TIMR Web Services
        Phone: 250.218.5284
        Eamil: mregan@timr.ca
        Website: timr.ca