We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 25287
    • 81 Posts
    I'm having a major headache trying to solve this. The manager login does not work. After putting in the username and password the login screen simply returns with the fields blank. The user details are correct, and when a wrong detail is entered an error shows up.

    This is a brand new install. I had been having the same trouble on the site, which I'm just starting to develop, so deleted and began again. I had been able to log in previously, but this week the problem showed up.

    I have cleared the cache and restarted my browser. I've followed the suggestions here http://rtfm.modx.com/revolution/2.x/getting-started/installation/troubleshooting-installation including adding the line
    php_value session.auto_start 0 to the .htaccess file. That simply produced a 500 error internal server error.

    The site is running modx 2.3.2 advanced with changes made to the core and manager locations as well as each of the config files as per http://rtfm.modx.com/revolution/2.x/administering-your-site/security/hardening-modx-revolution

    phpinfo shows the host is using php 5.2.17 and mysql v 5.1.68

    I have exhausted every fix I can find, and thought that a fresh install would sort it out.

    Any help would be greatly appreciated.

    This question has been answered by robinqld. See the first response.

      • 8274 ☆ A M B ☆
      • 222 Posts
      Just as a sanity check, does the username in question have access, via Access Control Lists, to the mgr context? And if so, is the role set to the minimal role allowed for that list?

      I had an issue with an EVO conversion like this, and it was mainly because the user was set to Member role on an ACL that required Super User role for mgr context access.
        • 25287
        • 81 Posts
        I have created a sudo user via php as per Bob's guide http://goo.gl/6p2xuV. Looking via phpMyAdmin the new user has sudo rights and is primary group 0, The other user is the manager that I set up when installing, is in primary group 1 and now has sudo rights.

        I ran the test_config script by Everett Griffiths. It gave the following errors, but the same errors occur on my working localhost setup. I have modified the beginning of the path for security.
        /modx/connectors/browser folder does not exist!
        /modx/connectors/context folder does not exist!
        /modx/connectors/element folder does not exist!
        /modx/connectors/layout folder does not exist!
        /modx/connectors/resource folder does not exist!
        /modx/connectors/source folder does not exist!
        /modx/connectors/workspace folder does not exist!

        The problem persists. I feel a like I'm going insane ... [ed. note: robinqld last edited this post 11 years, 9 months ago.]
          • 8274 ☆ A M B ☆
          • 222 Posts
          This is installed in a subdirectory in your web root, yes? Judging by the path, it looks like the whole thing should be installed in [your-web-domain-root]/modx/...

          If it isn't supposed to be in a subdirectory, then it looks like a possible path issue. Check your config.inc.php file to make sure your manager path is set properly (and other paths).
          • discuss.answer
            • 25287
            • 81 Posts
            Thanks Jason,
            my apologies, I pasted the report from my localhost setup (it was late at night!). Here's the output from my live setup, with the host01 in place of the real directory.

            Error
            The following errors were detected:

            /home/host01/public_html/connectors/browser folder does not exist!
            /home/host01/public_html/connectors/context folder does not exist!
            /home/host01/public_html/connectors/element folder does not exist!
            /home/host01/public_html/connectors/layout folder does not exist!
            /home/host01/public_html/connectors/resource folder does not exist!
            /home/host01/public_html/connectors/security folder does not exist!
            /home/host01/public_html/connectors/source folder does not exist!
            /home/host01/public_html/connectors/workspace folder does not exist!


            I have checked and rechecked paths, cleared the cache, restarted my browser ... currently tearing what little hair I have out.

            Solved, sort of. Had to delete everything and reinstall. So the cause is a mystery. [ed. note: robinqld last edited this post 11 years, 9 months ago.]