We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 40735
    • 119 Posts
    I recently discovered that a site I manage with MODX Revo has quit working. I get the error "Undefined class constant 'MYSQL_ATTR_USE_BUFFERED_QUERY'" for any page and the manager is a blank page. I have no idea what changed and Dreamhost was no help. So I'm trying to upgrade to 2.3.2 in the hopes that I can regain access to my site. But the only option I can select is "New Installation." Both the upgrade and advanced installations are disabled. I enabled the checkbox by manipulating the DOM with Chrome's dev tools and then clicked next but I got a 500 error. Is there something on the server that needs to be done to enable the upgrade?
      • 45533
      • 23 Posts
      well - did you tried to hardclean your cache ?

      also are the core files and stuff still in place ?
        • 40735
        • 119 Posts
        Quote from: aquabug at Dec 01, 2014, 10:06 AM
        well - did you tried to hardclean your cache ?

        also are the core files and stuff still in place ?

        If you mean did I clear my browser cache, yes. The core files are still in place but I appended "old" to all the dir names so I could upload the new files without overwriting the old ones. Should I not have done that?
          • 45533
          • 23 Posts
          i'd talked about the modx cache. revert all your changes. go to your components/cache directory and delete all files there.

          then check if the site is working again.

          if so - make a backup first wink

          then you should merge the new files with your old ones.... the renaming might be the reason for that deactivated upgrade checkbox.
            • 40735
            • 119 Posts
            I think I've discovered the source of the original problem. Removing the .htaccess file stopped the error from coming up. I compared my .htaccess file to the one from the modx installation package and discovered that mine had this in it:

            AddHandler php5-script .php

            I don't why that's there, what it does or how it got added but it appears to be the source of the problem. Without that line it works again.

            Edit: Well, the site works again but the manager is still a blank page.
              • 45533
              • 23 Posts
              glad to hear that smiley
                • 40735
                • 119 Posts
                I've been in touch with Dreamhost and at first they insisted they had not changed anything about anything but later they finally admitted that they added this line to my .htaccess file without telling me and that's what broke the site.