We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36671 ☆ A M B ☆
    • 120 Posts
    This client site was working fine but suddenly only the Manager is working. The front end is completely blank, not a single line of code is being generated.

    The most recent output from the error log is:

    [2014-11-07 15:43:04] (ERROR in xPDOConnection::connect @ /usr/local/pem/vhosts/147341/webspace/httpdocs/kellywalsh.ie/core/xpdo/xpdo.class.php : 3003) SQLSTATE[00000] [1130] Host '172.16.5.63' is not allowed to connect to this MySQL server
    [2014-11-07 15:43:04] (ERROR @ /index.php) Error preparing statement for query: SELECT `modSession`.`id` AS `modSession_id`, `modSession`.`access` AS `modSession_access`, `modSession`.`data` AS `modSession_data` FROM `modx_session` AS `modSession` WHERE `modSession`.`id` = ? - Array
    (
    [0] => 00000
    [1] =>
    [2] =>
    )

    [2014-11-16 01:07:08] (ERROR @ /index.php) Error 42000 executing statement:
    Array
    (
    [0] => 42000
    [1] => 1064
    [2] => You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '-10, 5' at line 1
    )

    But no new errors with today's date when I try to load a page.

    On the hosting server error log is the following:

    Thu Nov 20 10:21:17 2014] [error] [client 171.100.100.67] PHP Parse error: syntax error, unexpected $end in /usr/local/pem/vhosts/147341/webspace/httpdocs/kellywalsh.ie/core/cache/includes/elements/modplugin/3.include.cache.php on line 263

    Tried to manually clear cache but no solution.



    Any help appreciated. Thanks! [ed. note: intandem last edited this post 11 years, 10 months ago.]
      • 28107
      • 230 Posts
      Quote from: intandem at Nov 20, 2014, 04:10 AM
      ...SQLSTATE[00000] [1130] Host '172.16.5.63' is not allowed to connect to this MySQL server ...

      is the manager really working ?
      sounds as if the mysql server has gone or wrong password for the db.

      if the manager is working, try to publish a resource with a blank template
        CONIN Werbeagentur . Köln
        http://www.conin.de
        • 43240
        • 10 Posts
        Hi smiley

        Could you try opening
        /usr/local/pem/vhosts/147341/webspace/httpdocs/kellywalsh.ie/core/cache/includes/elements/modplugin/3.include.cache.php on line 263
        in your cache folder using quick update and see which snippet it is.

        if it is having an issue with one snippet you could try re installing it in case it has had code injected into it.

        Also you should try flushing all sessions in the manager in relation to the error in the database about not being able to read a session.

        If it is session related you could try running your front end interface sessionless (this might cause an issue if you have any kind of front end login) http://rtfm.modx.com/revolution/2.x/administering-your-site/settings/system-settings/session_enabled

        a final thing would be to check the config file to make sure it has not been altered in anyway. re installing modx overitself can usually fix a ton of issues also.

        i am not entirely sure what the issue is, i am pretty much throwing out what i would do in the situation. hope any of it helps

        Nad
          • 36671 ☆ A M B ☆
          • 120 Posts
          Turns out it was the same issue as detailed in this thread : https://forums.modx.com/thread/89564/warning-hacking-attack-on-revo-2-2-4-using-core-services-plugin. Thank you for all your input though. Appreciated as always. [ed. note: intandem last edited this post 11 years, 10 months ago.]
            • 19872
            • 1,078 Posts
            Hi inTandem! I had similar issue. Site would go down randomly for no consistent reason. Usually the client would call and say the site wouldn't load. I was trying to set up a cron job so I could determine when the site went down and for how long when Bob helped me discover the hack. All got resolved, though 2.3.1 did not work on the current platform so I had to switch to a different hosting plan and get cPanel.

            On another site though, very similar problem, but no evidence of the hack. After many many hours of troubleshooting and tracing the host error log, host support claimed that MODx was making too many requests and getting temporarily blocked. Host support tweaked something on their end and now the site has been working fine.