I can only say that the error should hopefully be found in some kind of log somewhere.
1) The MODX log? Since you can't get in manager, I wonder if you can read the log out of the database directly or filesystem to look. I don't know how to access the MODX log this way offhand.
2) PHP log. If you can access the PHP log, do it. If you can, turn on ALL PHP errors just to help you see if anything at all might be the case. You can even edit the main index.php file and use the the code
to see if you can get a response.
3) Apache error log, just in case something shows up there.
4) Browser log. Open development tools and look at the response codes of the page, is it a 200 or something else? Maybe only specific parts are failing to load?
5) Server logs. You may have a clue somewhere in access logs, or there is a "higher up" error that is caught by the server before it gets any farther down the chain.
Can you create a subdomain or subfolder of your hosting site and install a new fresh copy just to see if it works well? If so, you might look for differences in the database for anonymous access or group access, ACLs etc.
If even a fresh install doesn't work, I would be suspecting server configuration at that point, something not right in apache or PHP configs. Does your environment fully support requirements of that version of MODX?
I'm sure there is a solution here, probably a simple one.
If installing a fresh version works fine, I would suggest finding a MODX migration tool (they do exist) where you can use a fresh install, but migrate over your specific data and other settings.
Sorry you're having troubles!