We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 37582
    • 65 Posts
    Hey there,

    I got Articles 1.7.8 running on REVO 2.3.1. When trying to update it fails with:

    Console running...
    Attempting to install package with signature: articles-1.7.9-pl
    Package found...now preparing to install.
    Target directory is either not a directory or writable: http://localhost/mvz/packages/
    Could not transfer package articles-1.7.9-pl.transport.zip to http://localhost/mvz/packages/.
    Could not install package with signature: articles-1.7.9-pl


    I think the paths are set incorrectly. Question is: Where can I set the correct ones?

    This question has been answered by chrisissorry. See the first response.

      • 28042 ☆ A M B ☆
      • 24,524 Posts
      It should be using the MODX_CORE_PATH. Check your paths in your config files. Do you have any System or Context settings that might be different?
        Studying MODX in the desert - http://sottwell.com
        Tips and Tricks from the MODX Forums and Slack Channels - http://modxcookbook.com
        Join the Slack Community - http://modx.org
        • 37582
        • 65 Posts
        Hi Susan,

        in my core/config/config.inc.php it just says:

        if (!defined('MODX_CORE_PATH')) {
            $modx_core_path= 'C:/xampp/htdocs/mvz/core/';
            define('MODX_CORE_PATH', $modx_core_path);
        }


        which I think is correct. I do not have any extra system / context settings in place.
          • 3749
          • 24,544 Posts
          It looks like maybe there's a URL where a core path should be. Check the config.core.php files in the manager and connectors directories. Also, check the path in the first (and only) record in the modx_workspaces table.

          SiteCheck will check all the paths and URLs for validity for you (plus some other stuff): http://bobsguides.com/sitecheck-promo.html. It may not solve the problem, but it will at least rule a lot of stuff out.
            Did I help you? Buy me a beer
            Get my Book: MODX:The Official Guide
            MODX info for everyone: http://bobsguides.com/modx.html
            My MODX Extras
            Bob's Guides is now hosted at A2 MODX Hosting
          • discuss.answer
            • 37582
            • 65 Posts
            Alright guys, thank you very much. The problem still sits in front of the computer. I changed the core_path in the workspaces table when I moved the installation to my local server. It's not like it did not check that myself for nearly 500 times. It always said {core_path} like it's supposed to do. Well, I checked on the wrong database it seems. Got too many modx installations flying around.

            Thanks for the help - very much appreciated!