-
☆ A M B ☆
- 24,524 Posts
Attempting to directly access an unpublished resource by a non-Manager user results in a server 503 error. The OnPageNotFound event is not invoked.
As far as I can tell from looking at the code, accessing an unpublished resource should result in the page being treated as a not-found page. Why is the request resulting in a server 503 error, instead of the MODX error page, which is configured correctly and works as expected for non-existent resources?
If the resource is 'deleted', then it does trigger a not-found page.
The only things that come to mind are an error in a plugin connected to OnPageNotfound, or a problem with .htaccess. You could try disabling any such plugins and turning off FURLs and renaming .htaccess to see if it makes a difference.