We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 8822
    • 203 Posts
    I am having some serious issues with MIGX on a site that has been live now for over a year. Every time i try to add a new MIGX Item, using the 'Add Item' button, the loading icon appears indefinitely and a 403 error is displayed. In the log the following is outputted:
    [2014-09-29 09:03:03] (ERROR @ /manager/index.php) Error 42S02 executing statement: 
    Array
    (
        [0] => 42S02
        [1] => 1146
        [2] => Table 'sitename.modx_migx_configs' doesn't exist
    )

    The same appears if i try to update an item and if i go to the MIGX menu item under Components. All has been working perfectly, so what could have happened.
    The front end/data is not affected and my website is still displaying the correct data, but the manager is having serious issues. This affects hundreds of entries as well.
    Does anyone have any idea as to what could have caused this and more importantly how on earth i can fix it without losing all my data (which would be weeks and weeks of work).
    I am using Revo 2.2.14 and MIGX 2.6.8
    Many many thanks for any words of wisdom.
      • 8822
      • 203 Posts
      OK, so the issue i had above was actually down to the host changing some security settings last week and amending their mod security rules. The rules have now been disabled and i no longer get a 403 error or any hanging. Great! That said however, i am still getting the above error messages in the log - does anyone have any idea why?
      [2014-09-29 09:03:03] (ERROR @ /manager/index.php) Error 42S02 executing statement:
      Array
      (
          [0] => 42S02
          [1] => 1146
          [2] => Table 'sitename.modx_migx_configs' doesn't exist
      )


      Thanks folks!
        • 4172
        • 5,888 Posts
        seems the table modx_migx_configs wasn't created after installation.
        Newer versions of MIGX should do it automatically.

          -------------------------------

          you can buy me a beer, if you like MIGX

          http://webcmsolutions.de/migx.html

          Thanks!
          • 8822
          • 203 Posts
          What would be the best thing to do now then? I have a LOT of data already populated and it hasn't been a problem, infact the log only shows errors recently, which is odd since the site has been live for a year now. Do i need it? Should i update? If i do update do i run the risk of losing existing data or messing things up? Could i create it manually?

          Thanks for your help
            • 4172
            • 5,888 Posts
            You shouldn't have issues after upgrading to the newest version, but if you do not need any of the new features, you can create that table manually.

            You may not need that table, but MIGX is trying to access it on different places, what results in errors in the log, if it is not created.

            These are the steps, which was necessary to create the menue to the MIGX-CMP and within that CMP the MIGX-configuration-table(s):
            http://rtfm.modx.com/extras/revo/migx#MIGX-Step2%3ASetuptheMIGXConfiguratorCustomManagerPage%28CMP%29andPackageManager
              -------------------------------

              you can buy me a beer, if you like MIGX

              http://webcmsolutions.de/migx.html

              Thanks!