I am having some serious issues with MIGX on a site that has been live now for over a year. Every time i try to add a new MIGX Item, using the 'Add Item' button, the loading icon appears indefinitely and a 403 error is displayed. In the log the following is outputted:
[2014-09-29 09:03:03] (ERROR @ /manager/index.php) Error 42S02 executing statement:
Array
(
[0] => 42S02
[1] => 1146
[2] => Table 'sitename.modx_migx_configs' doesn't exist
)
The same appears if i try to update an item and if i go to the MIGX menu item under Components. All has been working perfectly, so what could have happened.
The front end/data is not affected and my website is still displaying the correct data, but the manager is having serious issues. This affects hundreds of entries as well.
Does anyone have any idea as to what could have caused this and more importantly how on earth i can fix it without losing all my data (which would be weeks and weeks of work).
I am using Revo 2.2.14 and MIGX 2.6.8
Many many thanks for any words of wisdom.