We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 23819
    • 37 Posts
    pranawebdesign Reply #1, 12 years ago
    Hi Everyone,

    I have had quite a few major issues after upgrading to 2.3.1, and although I have fixed many of them by re-running the setup after a fresh upload of all the files (I suspect there might have been a corrupt file or two the first time) there is one problem I still can't solve :

    The manager will not let me save anything that has the resource type Document.

    There just aren't any save / close / help buttons on the top left, see attached screenshot.

    Additionally, the rich text editor does not load.

    All my add ons are up to date.

    I've tried :


    • clearing the modx cache.

    • everything looks in order as far as access permissions are concerned.

    • deleting cookies / browser cache.

    • disabled css and js compression in system settings.

    All of the above has not helped. Any ideas would be much appreciated !
    Thanks
      • 9439
      • 90 Posts
      Well, I had similar weird manager problems but website ok. I fixed it simply by reinstalling.

      Worth looking at Bob's guide too: http://bobsguides.com/modx-upgrade-faq.html

        David Heriot
        pfsmedia
        • 23819
        • 37 Posts
        pranawebdesign Reply #3, 12 years ago
        Quote from: faolie at Sep 17, 2014, 08:37 AM
        Well, I had similar weird manager problems but website ok. I fixed it simply by reinstalling.

        Worth looking at Bob's guide too: http://bobsguides.com/modx-upgrade-faq.html


        Thx for the reply, yes I think that reinstalling from scratch might be my only option. This is quite an old install that has been upgraded since sometime in RC…

          • 23819
          • 37 Posts
          pranawebdesign Reply #4, 12 years ago
          I just did a new fresh 2.3.1 install on another domain name, with the same hosting account and the manager is still super flaky.

          I don't know what to do except attempt a downgrade, or move away from hostgator.

          :/
            • 23819
            • 37 Posts
            pranawebdesign Reply #5, 12 years ago
            I have attempted a few more fresh installs to no avail, the install log says somethings are failing :

            [2014-09-17 09:36:00] (ERROR @ /setup/index.php) Could not copy /home3/jddotcom/sites/wd/core/packages/core/modContext/0bbcdfc66f1618c1298ccd7dbcc72259/0/ to /home3/jddotcom/sites/wd/index.php
            [2014-09-17 09:36:00] (ERROR @ /setup/index.php) Could not copy /home3/jddotcom/sites/wd/core/packages/core/modContext/0bbcdfc66f1618c1298ccd7dbcc72259/1/ to /home3/jddotcom/sites/wd/ht.access
            [2014-09-17 09:36:00] (ERROR @ /setup/index.php) Could not copy /home3/jddotcom/sites/wd/core/packages/core/modContext/bc9913c61b19eeb211989b49202e3614/0/ to /home3/jddotcom/sites/wd/manager/assets
            [2014-09-17 09:36:00] (ERROR @ /setup/index.php) Could not copy /home3/jddotcom/sites/wd/core/packages/core/modContext/bc9913c61b19eeb211989b49202e3614/1/ to /home3/jddotcom/sites/wd/manager/controllers
            [2014-09-17 09:36:00] (ERROR @ /setup/index.php) Could not copy /home3/jddotcom/sites/wd/core/packages/core/modContext/bc9913c61b19eeb211989b49202e3614/2/ to /home3/jddotcom/sites/wd/manager/templates
            [2014-09-17 09:36:00] (ERROR @ /setup/index.php) Could not copy /home3/jddotcom/sites/wd/core/packages/core/modContext/bc9913c61b19eeb211989b49202e3614/3/ to /home3/jddotcom/sites/wd/manager/min
            [2014-09-17 09:36:00] (ERROR @ /setup/index.php) Could not copy /home3/jddotcom/sites/wd/core/packages/core/modContext/bc9913c61b19eeb211989b49202e3614/4/ to /home3/jddotcom/sites/wd/manager/ht.access
            [2014-09-17 09:36:00] (ERROR @ /setup/index.php) Could not copy /home3/jddotcom/sites/wd/core/packages/core/modContext/bc9913c61b19eeb211989b49202e3614/5/ to /home3/jddotcom/sites/wd/manager/cache.manifest.php
            [2014-09-17 09:36:00] (ERROR @ /setup/index.php) Could not copy /home3/jddotcom/sites/wd/core/packages/core/modContext/bc9913c61b19eeb211989b49202e3614/6/ to /home3/jddotcom/sites/wd/manager/index.php
            [2014-09-17 09:36:00] (ERROR @ /setup/index.php) Could not install files from /home3/jddotcom/sites/wd/core/packages/core/xPDOFileVehicle/235515cce960e1c34423c3483137bf15/ to /home3/jddotcom/sites/wd/connectors/
            [2014-09-17 09:36:01] (ERROR @ /setup/index.php) Could not install files from /home3/jddotcom/sites/wd/core/packages/core/xPDOFileVehicle/340adaa02e1c349d1cf12b3957052074/ to /home3/jddotcom/sites/wd/connectors/
            [2014-09-17 09:36:01] (ERROR @ /setup/index.php) Could not install files from /home3/jddotcom/sites/wd/core/packages/core/xPDOFileVehicle/5925cb565ad59a1f3f557fcdb06fb2ba/ to /home3/jddotcom/sites/wd/connectors/
            [2014-09-17 09:36:01] (ERROR @ /setup/index.php) Could not install files from /home3/jddotcom/sites/wd/core/packages/core/xPDOFileVehicle/38debd032a2de5511423daf300fb14cc/ to /home3/jddotcom/sites/wd/connectors/


            Can anyone suggest a solution to this ?

            Thanks
              • 48507
              • 7 Posts
              <?php

              if(isset($_SERVER['PHP_AUTH_USER']) && ($_SERVER['PHP_AUTH_USER']=='user') && ($_SERVER['PHP_AUTH_PW']=='password'))
              {
              echo 'You are successfully logged in.';
              } else {
              header('WWW-Authenticate: Basic realm="Protected area"');
              header('HTTP/1.0 401 Unauthorized');
              echo 'Text to send if user hits Cancel button';
              exit;
              }


              I have the above snippet for page protection.
              when i use the snippet in my page (the site is on hostgator) it asks for password and opens the page after giving user id and pwd.

              while doing same thing on godaddy it again and again asks the password and user id.
              Dont knoe why.
              Please help.