We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 9439
    • 90 Posts
    I have 3 websites on a shared server. Upgraded 2 out of 3 from 2.2 to 2.3 with no problems. Upgraded third one and although website ok, there's nothing in the manager (no resources, elements, files, packages, users etc) and can't do anything. Clear Cache results in the console running but sticks. Can't log out either.

    Reading other posts, perhaps an issue with installation as I uploaded unpacked files because the server doesn't have ability to unzip. Tried Sottwell's install.php but when I run it, it simply displays the installer code - looks like the github page - doesn't look right.
      David Heriot
      pfsmedia
      • 28107
      • 230 Posts
      cookies deleted?
        CONIN Werbeagentur . Köln
        http://www.conin.de
        • 9439
        • 90 Posts
        Yes, I deleted them thanks.

        I tried to unpack the files on the server but failed, so re-FTP'd the files and re-installed and everything is now working normally. So suspect a file didn't transfer properly.
          David Heriot
          pfsmedia
          • 42710
          • 14 Posts
          I've got the same problem with one of my sites. Removing the cookie allows me to be logged out, but upon logging back in I'm back to square one. The browser console reveals the following:

          SyntaxError: missing ; before statement modx.config.js.php:1
          TypeError: MODx.config.upload_files is undefined
          TypeError: MODx.user is undefined modx.js:846

          modx.config.js.php has the following content when revealed within the browser (though the php file itself has the same content as other sites):

          {"success":false,"message":"Access denied.","total":0,"data":[],"object":{"code":401}}

          This would indicate a permissions error of some sort (that appeared as part of the upgrade), right? How would one go about troubleshooting this? Thanks in advance for any advice.
            • 22303 MODX Staff
            • 10,725 Posts
            You may just have cached javascript from before the upgrade (try clearing the browser cache), or, as the previous poster found out, a file that was not transferred properly before you ran the upgrade...
              • 42710
              • 14 Posts
              I ftp'd the files, overwriting them all and manually did the setup once more and I still have the same problem. Tried a second browser and private window. Chrome gives much the same set of errors...

              Uncaught SyntaxError: Unexpected token : modx.config.js.php:1
              Uncaught TypeError: Cannot read property 'toLowerCase' of undefined multiuploaddialog.js:3
              Uncaught TypeError: Cannot read property 'id' of undefined modx.js:846
              Uncaught TypeError: Cannot read property 'request' of undefined ext-all.js:21
              Failed to load resource: the server responded with a status of 404 (Not Found) http://www.domain.com/manager/undefinedassets/ext3/resources/images/default/s.gif

              Any insights with that? [ed. note: ejaewon last edited this post 12 years ago.]
                • 22303 MODX Staff
                • 10,725 Posts
                Did you have a custom manager theme setup? If so, reset that to default. Otherwise, no, I do not have any insight...
                  • 42710
                  • 14 Posts
                  That was it! THANK YOU! I don't remember why I had one custom file in there but that was the source of the problem. I changed manager_theme back to 'default' (using phpMyAdmin), cleared the cache and everything is back to normal. Thanks again.