We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 21671
    • 244 Posts
    I just upgraded a site from 2.14 (I think) to 2.31. Now I try to edit a resource, chunk, template. Anything. I then save it. I get the save successful message. I close file and reopen it and the changes are gone. I don't understand.
    I cleared browser cache, cleared site cache, flushed permissions...

    I have disabled as many plugins as I could. These are error log messages:

    [2014-09-14 23:23:36] (ERROR @ /connectors/modx.config.js.php) Error caching lexicon topic lexicon/en/core/default
    [2014-09-14 23:23:56] (ERROR @ /paas/xxxx/www/core/xpdo/xpdo.class.php : 653) PHP warning: file_exists(): open_basedir restriction in effect. 


    Thoughts?

    Many Thanks,

    Noah
      • 5160
      • 118 Posts
      chris.dempsey78 Reply #2, 12 years ago
      Does it help if you clear the cache by FTP rather than using the Manager?

      I've experienced a similar issue and this is the only thing I did differently.

      I didn't need to disable plugins but I know all the one I use are stable on 2.3.1.
        • 21671
        • 244 Posts
        No, unfortunately it doesn't help. To be clear, i can save, and it looks like it takes. If I leave page and come back, the changes are gonzo.

        -N
          • 5160
          • 118 Posts
          chris.dempsey78 Reply #4, 12 years ago
          Only other time I've seen that happen the cause was normal MODX usage triggering a mod_security rule at the data centre.

          What do you see in the Net panel of the debugger in Firefox or Chrome? When I had these symptoms the POST request to save the changes returned 404. I doubt this is what's affecting you but with a look.