We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 10600
    • 9 Posts
    A MODX noob here using Revo 2.3.1.


    Have a new multi-site setup with under construction pages for now. The excellent video tutorials got me through setting up a Template with my markup and splitting out the content to a Resource. My new pages were previewing until I realized they were also being displayed on the public-facing site. I made some changes that turned off publication of the new Resources and designated the under construction resource in the Gateway Manager as the starting page for the site I'm working on.

    Now I can't get a preview of the Resources I'm editing. I searched this forum but didn't find this exact situation, but clearing caches seemed to be in order. Here's what didn't work:

    1. Cleared the browser cache.
    2. Cleared the MODX caches (Manage> Clear Cache).
    3. Clicked the [View] button (the under construction page was displayed).
    4. Switched to another browser in a VM and repeated 1–3 (with the same result).
    5. Logged out of all instances of the MODX Manager, logged back in, and repeated 1–3 (same result).

    Lastly, here are today's entries from the error log:
    [2014-09-07 02:57:19] (ERROR @ /2/connectors/index.php) Error caching action map mgr/actions
    [2014-09-07 02:58:05] (ERROR @ /2/connectors/index.php) Error caching lexicon topic lexicon/en/core/default
    [2014-09-07 02:58:05] (ERROR @ /2/connectors/index.php) Error caching action map mgr/actions
    


    Thanks for any suggestions,

    —Michael
      • 3749
      • 24,544 Posts
      Make sure you have the following tag in the head section of all templates (note the exclamation point):

      <base href="[[!++site_url]]" />


      Also, make sure the core/cache directory is writable.

        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 10600
        • 9 Posts
        Quote from: BobRay at Sep 08, 2014, 12:53 AM
        Make sure you have the following tag in the head section of all templates (note the exclamation point):

        <base href="[[!++site_url]]">


        Also, make sure the core/cache directory is writable.


        Thanks, Bob. I substituted your code (which I did have wrong—I had started the tutorial on wiki.modx.com but got the feeling that is old info and missed the base url when I updated the tags). What, by the way, is the significance of the exclaimation mark?

        Permissions are 755 on the core/cache directory. Changes are being maintained across browser sessions.

        Cleared browser cache, restarted Firefox, cleared MODX caches and still no success.

        —Michael
          • 10600
          • 9 Posts
          This problem is solved (as far as my limited understanding of MODX can determine).

          After a bit more noodling around I found that when setting up the domain I'm editing I specified a Startpage in the Gateway Manager plugin and I inadvertently caused the problem. Deleting any specific selection, leaving it to read, "Default page," and the [View] button produced the expected result of displaying the Resource that was currently being edited.

          —Michael



            • 3749
            • 24,544 Posts
            I'm glad you got it sorted. My next bit of advice would have been to start disabling plugins. wink

            Thanks for reporting back.
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 10600
              • 9 Posts
              Looks like I didn't solve it—the Gateway Manager needs the Startpage value to work. So I can use the plugin and have multiple sites or code blind (not a good idea for me).

              I'll try to check with the developer or try one of the other "context switching" plugins. BTW, how do you get in touch with an Extra developer?