I have MODX 2.2.10 and the basics seem to work. Trying to establish in the front-end a password-potected member area I obtain an internal server error 500 when acesing the front-end pages.
From the various sources I learned that I have to
(1) assign the users to be admitted to a user group (eg admuser),
(2) assign the resources/pages to be protected to a resource group (eg protdocs),
(3) set in the defined user group that they may access the resources in the defined resource group in the web context (=front-end, if I'm right).
Doing this leads to a login window that pops up when accessing the protected page (entered into group protdocs) in the front-end. I enter name and password of an admitted user (entered into admuser). The result is an internal server error 500.
Something missing in my settings? My .htaccess in the root is that from MODX for enabling FURLs, nothing else.
Further question: The above is from a remote server. When doing the same on a xampp localhost server, it all has no effect, meaning that I obtain the protected page as if no protection is set. Do the protection mechanisms behave different on a localhost compared to remote?
And since I am asking, I continue: Can I use the .htaccess password mechanism with MODX? .htaccess goes on directories. FURLs in combination with parent-child relationships amongst resources seem to create kind of "virtual" directories. I can create a parallel real directory and place a .htaccess there (or perhaps do it via httpd.conf). But my efforts so far had no success.
Thank you in advance
Axel
-
☆ A M B ☆
- 24,524 Posts
Are you using the Login snippet to provide the front-end login?
Thank you for answering.
No I don't use the Login snippet. Do I have to or is it an option? I read somewhere that it exists, but didn't recognize that it is necessary, if it is.
Best regards
Axel
-
☆ A M B ☆
- 24,524 Posts
That is how you provide a login form for front-end users.